PP: Dragging from Location Input to other programs fails in X

VERIFIED DUPLICATE of bug 9642

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 9642
19 years ago
18 years ago

People

(Reporter: jafl, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview description:

Clicking and dragging the icon at the left of the location input field
to another program that supports XDND doesn't transfer the text.

Steps to reproduce:

1) Download

  ftp://ftp.pma.caltech.edu/pub/jafl/xdnd/xdnd-v4-binary-Linux-Intel.tgz

  This is for use on Linux glibc 2.1 systems.  I can provide the source if you
  need to run it on a different Linux/UNIX variant.

2) Click and drag icon at the left of the location input field in Mozilla.

3) Observe the output printed by the XDND test binary:

   a) The data type "application/x-rootwin-drop" should actually be
      "application/x-rootwindow-drop" as specified in the XDND v4 spec at
      http://www.newplanetsoftware.com/xdnd/drop_on_root.html

   b) The drop action doesn't change when the Meta key is pressed/released,
      only when the mouse is moved after pressing/releasing the Meta key.
      (The drop will only be accepted when the action is "copy")

   c) When the mouse is released, the drop fails because the data type
      "text/plain" cannot be retrieved by the XDND test program.  (The test
      program will automatically print the contents of "text/plain" if it can
      retrieve it.)

   d) When the drop action is "ask" (by holding down the Meta key), the test
      program is unable to complete the drop because the action list contains
      two actions while the description list is empty.  This is explained at
      http://www.newplanetsoftware.com/xdnd/ in the Technical Details section
      under XdndActionList and XdndActionDescription.

Updated

19 years ago
Assignee: joki → pinkerton

Comment 1

19 years ago
Pink, not sure if you handle Linux dnd as well but I'll let you figure who to
drop this on.
Assignee: pinkerton → blizzard
yeah, d&d is not yet implemented on linux/gtk. reassigning to blizzard.
adding myself to the cc list.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 9642 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
[bugday] verifying as duplicate, linux drag drop support - targetted for M14.
(Assignee)

Comment 6

18 years ago
Please ignore the spam.  Changing address.
Assignee: blizzard → blizzard
Status: VERIFIED → NEW
(Assignee)

Comment 7

18 years ago
bustage from my reassign
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
(Assignee)

Comment 8

18 years ago
bustage from my reassign
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.