Repulsive picture remniscent of Nazi Germany propaganda.

VERIFIED INVALID

Status

defect
--
critical
VERIFIED INVALID
17 years ago
7 years ago

People

(Reporter: thinkerdreamer, Assigned: mitchell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

I think it would be wise to take this picture down.

1. The star is remniscent of the Nazi star
2. The men saluting are also remniscent of Nazi Soldiers. Look at the way the
hand is positioned in the air!

I think it is grotesque to have anything related to or mimicking Nazi Germany.
Think of all the people that faught that insane government in World War II. I
think they would be apalled. Mozilla shouldn't be tied with NeoNazi's in a
poorly made pic for a party that has long past on mozilla.org's web site. That
pic should be removed at once.

What if a member of the press saw this piece of trash?!

To promote Mozilla you have to care for the user and the user would be shocked
at this outrageous pic!


Reproducible: Always

Steps to Reproduce:
1. Click on the link.
2. Look at the grotesque picture.
3.

Actual Results:  
I was shocked, apalled, my stomach churned etc.

Expected Results:  
Mozilla.org should have never, ever, messed around with Nazi-isms.
i think this is wontfix. you are really grasping at straws here. the problem is,
i dont know who would be the best person to give an official opinion...

-->asa
Assignee: endico → asa
QA Contact: imajes → Malachi
Reporter

Comment 2

17 years ago
Actually, I made a hasty generalization.  There are only two things that mimic
the Nazi's and that is the salute and the color of red.  Some have referred this
image to communism or socialism. Others may argue that it has some religious
overtones like the men are actually worshipping the dragon. So you agree that it
would be beneficial for the press to see such a picture?  You're the boss, but I
see bad PR in it.    
i was thinking along the lines of socialism myself, but thats just me.

and i dont speak for mozilla.org... that would be way too much pressure and i 
have _nowhere_ near the required experience for that ;) mitchell@mozilla.org or 
asa@mozilla.org should give their opinion.

now that i think about it, this is mitchells bug, bouncing to her.
Assignee: asa → mitchell

Comment 4

17 years ago
This is not a bug. 

Constructivist art is a recongnized genre and not "Nazi Germany propaganda".
Perhaps you can find an art history textbook or online documentation to educate
yourself about 20th century artwork.
 
See some completely not-nazi examples like this British propaganda artwork at
http://www.wkac.ac.uk/poster/imagebank/Images/WomenofBritainComeintothefactories.jpg
 or this American propaganda at
http://www.artfightsback.org/images/posters/Let%27sGoUSA.gif (note the red star
which many have claimed to be "communist"). 

There is nothing in the image you link to that has anything to do with nazi
germany. Your revulsion is misplaced.  
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
Verified INVALID
Status: RESOLVED → VERIFIED
Reporter

Comment 7

16 years ago
I still disagree that this isn't the Socialist star that the game show "Weakest
Link" describes, but if you don't like this bug, delete it. 

Comment 8

16 years ago
I like the gif, to me it simbolizes the front line coders and army of testers
who sacrafice there time to develop somthing better, in the name of the Lizard,
that is mozilla!
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.