onchange event-handler in <select> works if you use the mouse to change, not if you use the arrow keys

RESOLVED DUPLICATE of bug 126379

Status

()

Core
DOM: Events
--
minor
RESOLVED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: bugzilla, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

If you've got a <select> and use the onchange event handler, it only fires the
event by using the mouse to change the selected option, not if you use for
example the arrow keys.

Reproducible: Always

Steps to Reproduce:
1.Make a <select> with 2 options and onchange="alert('blablabla');" (of course
in a valid html-construct with head and body ;) )
2.Open the file

Actual Results:  
mozilla did show me the alert fenster by selecting an option with the mouse, not
wby changing with the arrow keys.

Expected Results:  
it should show the alert-window by changing the selected option. like you're
changing the selected option with the mouse ;D

Comment 1

15 years ago
that behaviour would break too many sites.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.