Conn: "localhost" does not load, 127.0.0.1 or actual IP address work

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: lists.all, Assigned: darin.moz)

Tracking

({verifyme})

Trunk
x86
Linux
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

In all other browsers, including Mozilla 1.2.1, I can access http://localhost/.
In  1.3b, I get a popup stating "Document contans no data". If specifying
127.0.0.1 or the actual IP address, it works except for hardcoded references to
localhost.

Reproducible: Always

Steps to Reproduce:
1.Type http://localhost/
2.
3.

Actual Results:  
Document contains no data.

Expected Results:  
Load same results as for 127.0.0.1 or actual IP address.

Comment 1

16 years ago
dup of bug 189965, or rather the linux variant of it in bug 193267
Resolving as such. Please add comment if this is not fixed in builds from the
19th or later.

*** This bug has been marked as a duplicate of 193267 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: localhost does not load, 127.0.0.1 or actual IP address work → localhost does not load, 127.0.0.1 or actual IP address work

Comment 2

16 years ago
I don't know why localhost would trigger this error message, and investigate
further.
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Networking
QA Contact: asa → benc
Resolution: DUPLICATE → ---

Comment 3

15 years ago
->default contacts
Assignee: asa → darin

Comment 4

15 years ago
Lars: any update on this problem?
Summary: localhost does not load, 127.0.0.1 or actual IP address work → Conn: "localhost" does not load, 127.0.0.1 or actual IP address work

Comment 5

14 years ago
RESOLVED/WFM:

I think this has been working for sometime, Mozilla 1.7.5/macos for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago14 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.