HTTP headers bleed into layout

RESOLVED DUPLICATE of bug 197426

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 197426
15 years ago
15 years ago

People

(Reporter: Judson Valeski, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
using winxp trunk build 2003022108.

steps to reproduce:

1. sign into your account at shutterfly.
2. click on various buttons like "albums" "projects" etc.
3. about 50% of the loads cause HTTP headers (pragma, cookie, response code,
others) to show up in the document at the top.

this is also causing script errors on some of the pages.
(Assignee)

Comment 1

15 years ago
WFM build 2003021608 win2k w/ or w/o pipelining enabled.
(Assignee)

Comment 2

15 years ago
WFM build 2003022308 win2k w/ or w/o pipelining enabled.  however, with
pipelining enabled, i did occasionally notice an image fail to load (always the
2nd image of the 3 in my album).  otherwise, the site seemed to work well.  this
could be connection speed dependent.  i have a DSL connection here.
(Assignee)

Comment 3

15 years ago
bug 193546 looks like a duplicate.
(Reporter)

Comment 4

15 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=193546 does look like a dupe. I'm on
a 65kb/sec DSL connection.

the image problem is orthogonal (I've been seeing that for years w/ moz builds).
(Reporter)

Comment 5

15 years ago
Created attachment 117599 [details]
screenshot of the problem (in NS7)

this screenshot is from NS7 (not mozilla trunk) and I'm providing it just as a
datapoint.

Comment 6

15 years ago
I am seeing very similar symptoms, but not sure if it is the same bug.

Browser: mozilla 1.3 on linux.

page1 contains a 302 header, and redirects to page2.  page2 is displayed, but
above it can be seen the bottom of page1, and the http headers for page2.

i did a packet dump, and can see that page1 required two tcp packets, and that
what i am seeing rendered above the content of page2 is the second of these packets.

also, after page2 (and crud above it) is rendered mozilla continues to wait for
more data not believing the page has been loaded.

Comment 7

15 years ago
Created attachment 120035 [details]
shows page1, page2's headers, page2 content

Added an image showing the output.
(Assignee)

Comment 8

15 years ago
please try mozilla 1.4 alpha.  this is a duplicate most likely.

*** This bug has been marked as a duplicate of 195746 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

15 years ago
I just saw something wierd at shutterfly w/ moz, winxp, trunk 2003041208 build.

rather than "bleeding into layout" all of the HTTP traffic played out in the
content area. multiple requests *and* their responses, all in plain text in the
content area. no "regular" page layout occured.
(Reporter)

Comment 10

15 years ago
reopening.

seeing this w/ winxp, 2003041208 moz trunk build.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 11

15 years ago
Created attachment 121493 [details]
screenshot of the problem on another site.

seeing this at http://www.stvlive.com/guests.html as well.

Comment 12

15 years ago
this looks like bug 197426.

Comment 13

15 years ago

*** This bug has been marked as a duplicate of 197426 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.