Closed Bug 19482 Opened 26 years ago Closed 5 years ago

exim server's response to 'RCPT TO:' not handled properly

Categories

(MailNews Core :: Networking: SMTP, defect, P5)

x86
Windows 95
defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: dave, Unassigned)

Details

(Whiteboard: [nsbeta2-])

Attachments

(3 files)

I cannot send any mail. I always get a message like "An (SMTP) error occurred while sending mail. Server responded <dave@royal.freeuk.com> is syntactically correct" where 'dave@royal.freeuk.com' was the 'to' address - ie myself, and it *does* say 'correct'. (This happens with any 'to' address.) I have read bugs 18084 & 19026 - is this a case of the latter? Mozilla pref lines: user_pref("mail.smtp_name", "royal"); user_pref("mail.smtpserver.smtp1.hostname", "relay.freeuk.net"); user_pref("mail.smtpserver.smtp1.username", "royal"); (Same result if I delete the last of those) They were converted from NC4.5 prefs: user_pref("mail.smtp_name", "royal"); user_pref("network.hosts.smtp_server", "relay.freeuk.net"); Build ID 1999111520 Windows 95
QA Contact: lchiang → esther
Assignee: ducarroz → sspitzer
I just sent a message to dave@royal.freeuk.com and apparently works fine. I reassign this bug to sspizter
Status: ASSIGNED → RESOLVED
Closed: 26 years ago
Resolution: --- → INVALID
Based on the attachment, it appears that this is a server configuration error. I don't think the error message is coming from mozilla -- I think it's coming from the server. Marking invalid.
Status: RESOLVED → REOPENED
I just saw this error too. The server is exim v2.05 on FreeBSD with a fairly standard setup. Doing a manual smtp session: > [10:20:27 edwin@wit387304 edwin] telnet localhost 25 > Trying 127.0.0.1... > Connected to localhost. > Escape character is '^]'. > 220 wit387304.student.utwente.nl ESMTP Exim 2.05 #1 Tue, 21 Dec 1999 10:22:50 +0100 > HELO woudt.nl > 250 wit387304.student.utwente.nl Hello localhost [127.0.0.1] > MAIL FROM:<edwin@woudt.nl> > 250 <edwin@woudt.nl> is syntactically correct > RCPT TO:<edwin@djo.nl> > 250 <edwin@djo.nl> is syntactically correct > DATA > .... Instead of the standard '250 ok', this mailserver apparently replies a bit different. However a 250 result code already implies that the message was sent ok, so mozilla should not care. This is also specified in RFC821 (SMTP): > The number is intended for use by automata to determine what state to enter > next; the text is meant for the human user. It is intended that > the three digits contain enough encoded information that the > sender-SMTP need not examine the text and may either discard it or > pass it on to the user, as appropriate. Because of this violation of RFC821 I'm reopening this bug. PS: The error shown is the error for the recipient (RCPT TO), apparently mozilla already accepts the reply for the sender (MAIL FROM).
Resolution: INVALID → ---
Hmm... I just looked at the code (mailnews/compose/src/nsSmtpProtocol.cpp) and it seems correct.
I tried telnet session with relay.reeuk.net - same result as Edwin. See attachment. I sent a message with two recipients and it reported, in the error box, the email address in the second one, so it does apppear to accept the RCPT TO command. This suggests to me that the "syntactically correct" text is hanging around and being incorrectly displayed as a result of some later error. However, the next reply, 354, and the rest of the session looks OK to me. Tricky.
Target Milestone: M13 → M14
moving to m15
Status: REOPENED → ASSIGNED
Target Milestone: M14 → M15
Just keeping this bug alive. I've now tried it with M14 under Linux. Different error message: "Alert: Sending of message failed" Same SMTP server (relay.freeuk.net) as before.
sliding to m16. sorry everyone. too many bugs, not enough time.
Target Milestone: M15 → M16
Is there an actual bug here? Please describe what needs to be fixed. Marking M17.
Target Milestone: M16 → M17
Well.... Mozilla mailnews does not work with exim. It's not a server configuration problem, it is mozilla that does not accept a valid (according to RFC821) response to the 'RCPT TO:' command. My comments from 1999-12-21 explain this in a little more detail.
Changing cryptic summary to reflect actual bug. Nominating nsbeta2 since we're not compliant with the RFC.
Keywords: nsbeta2
Summary: SMTP error sending mail: <...> is syntactically correct → exim server's response to 'RCPT TO:' not handled properly
I just tried sending a message to grobh@sun.ac.za, and my smtp server was mail.sun.ac.za (ESMTP Exim 2.10) I had no problems. 250 mail.sun.ac.za Hello h-198-93-95-225.netscape.com [198.93.95.225] MAIL FROM:<netscape.com> 250 <sspitzer@netscape.com> is syntactically correct RCPT TO:<grobh@sun.ac.za> 250 <grobh@sun.ac.za> is syntactically correct DATA are you still seeing this bug? is so, do you have a server I can use to reproduce?
You can use 130.89.234.74 (idefix.student.utwente.nl) and send messages to sspitzer@woudt.nl (they will be sent to you). I'm currently downloading the latest nightly build.
Ok, this is interesting. Sending mail still fails, however I now get this error. I can't really make sense of it... | An error occurred sending mail: SMTP server error. The server responded: | wit387304.student.utwente.nl Hello woudt.nl [10.235.121.14] | SIZE | PIPELINING | HELP Contact your administrator for assistance.
Apparently the error above only happens the first time. On all subsequent attempts I get this error: | An (SMTP) error occured while sending mail.Server reponded: | <sspitzer@woudt.nl> is syntactically correct I cannot reproduce the first error by restarting mozilla or by deleting the profile directory.
Putting on [nsbeta2+][6/01] radar. This work must be done by 06/01 or we may pull this for PR2.
Whiteboard: [nsbeta2+][6/01]
ok, I'm able to reproduce this thanks to edwin. debugging now.
Target Milestone: M17 → M16
testing a potential fix...I hope to check this in tonight, marking m16.
fix in hand, going to get it reviewed now.
Status: ASSIGNED → RESOLVED
Closed: 26 years ago → 26 years ago
Resolution: --- → FIXED
marking fixed. r=mscott. sorry this bug was open so long.
The fix violates this directive of section 5.2.10 of RFC 1123. Reopening. > Whenever possible, a sender-SMTP SHOULD test only the > first digit of the reply code, as specified in Appendix E of RFC-821. And why are you looking for both 3xx and 2xx in the same place? The fix makes no sense.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
john, are you saying the problem is that I'm testing for all three digits, instead of just the first, or are you saying something else? please elaborate. dave / edwin: is the most recent build working for you?
Status: REOPENED → ASSIGNED
I am saying that the problem isn't fixed, the symptom has just been papered over by ignoring out-of-sync replies. The current code can ignore real failures because it is out of sync and doesn't see them. In this case, the user's message would be silently dropped. I am presuming the only reason the client would get a 2xx to DATA or a 3xx to the final "." would be that replies are out of sync. I unfortunately cannot try out the server myself due to iplanet firewall issues. In addition, both the existing code and the fix violate the specification by looking at the second and third digits for no good reason.
ok, thanks for the additional info. I'll look into fixing this the right way.
Due to slip in schedule, moving this bug from [6/01] to [Will be minus on 6/15] for fix deadline.
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][Will be minus on 6/15]
moving to m17, since it is not a m16 blocker.
Target Milestone: M16 → M17
Cleaning up status whiteboard by marking beta2 minus (we're past 6/15} It appears that folks are too doomed to handle this for beta2. What is the market share of servers impacted by this issue? i.e., How common is this problem? Adding relnote keyword as well. Thanks, Jim
Keywords: relnote
Whiteboard: [nsbeta2+][Will be minus on 6/15] → [nsbeta2-]
changed relnote to relnote2 so it gets considered/included for beta2 notes. I may solicit help from someone, maybe mscott?, in pinpointing the wording for a release note. cc mscott.
Keywords: relnote → relnote2
Thought I'd try M18. Same error "Alert: Sending of message failed" I'm now using Linux behind a SOCKS proxy. Same mail server. Why is this failure so rare? It's a blocker for me! Dave Royal
It seems unclear to me whether this bug requires either of a "developer" or "user" release note. If anyone feels it does, can they please draft one and then nominate with the relnote-user or relnote-rtm strings in the Status Whiteboard. Thanks :-) Gerv
smtp -> jefft
Assignee: sspitzer → jefft
Status: ASSIGNED → NEW
Attached patch A fix — — Splinter Review
Adding mail3 keyword ...
Keywords: mail3
reassigning jefft's bugs to naving
Assignee: jefft → naving
marking nsbeta1-. However, if jefft's patch from 11/13 works, let's take it.
Keywords: nsbeta1-
Clearing very old milestone (M17) in hope of reevaluation. Adding "patch" keyword.
Keywords: patch
Target Milestone: M17 → ---
over to the owner
Assignee: naving → mscott
Component: Composition → Networking - SMTP
QA Contact: sheelar → nbaca
Both the attached patch and the current code fail to address the problem I mentioned in comment #28. By accepting 3XX responses to RCPT and 2XX responses to DATA, Mozilla is failing to detect real errors when replies get out of sync, leading to potential silent loss of email.
Product: MailNews → Core
Assignee: mscott → nobody
Product: Core → MailNews Core
QA Contact: nbaca → networking.smtp
Priority: P2 → P5

Version 91 has all new smtp backend code. If you can still reproduce this issue, please file a new bug report https://bugzilla.mozilla.org/enter_bug.cgi?product=MailNews%20Core&component=Networking%3A%20SMTP

Status: NEW → RESOLVED
Closed: 26 years ago → 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: