URL Bar: CTRL+Shift+Left/Right Arrows should select a single word at a time

VERIFIED DUPLICATE of bug 98546

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 98546
15 years ago
14 years ago

People

(Reporter: Prognathous, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030108
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030108

Mozilla does implement these key combinations for single-line and multi-line
textareas, but not for the URL Bar.
In any version of Windows, the selection is preformed for a single word at a
time, not for the whole line (as currently happens in Mozilla).


Reproducible: Always

Steps to Reproduce:
1. Press Alt+D to place the caret in the URL Bar
2. Press CTRL+Shift+Left Arrow


Actual Results:  
The whole line is deselected

Expected Results:  
Only the last word should be deselected (compare with IE, Windows Explorer and
the Start->Run dialog)


If these keyboard shortcuts don't collide with other shortcuts, please add them
to other platforms as well.

Comment 1

15 years ago
wfm on XP Pro SP1 & Moz 2003022408.

Note : the shortcut key to put the caret in the URL bar is CTRL+L and not ALT+D
which is for IE. In Moz ALT+D works sometimes, but if you try it on this page it
probably won't.

Comment 2

15 years ago
Always try a current nightly before submiting bugs. This onw has already been fixed.

*** This bug has been marked as a duplicate of 98546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Check that you don't have a
user_pref("layout.word_select.stop_at_punctuation", false);
line (or similar) in your profile's prefs.js file.

This should already work in 1.3b. I think you have a nightly build that predates
the fix to this bug by about one day. :-)
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
*** Bug 207473 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.