Personal toolbar & imported favorites keep reverting to default when Mozilla quits

RESOLVED DUPLICATE of bug 192124

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 192124
15 years ago
13 years ago

People

(Reporter: Alex Yourke, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

Similar problem to ID#114824 except my customized Personal Toolbar is lost after
a normal quit, not a crash. Also I am running MacOS 10.2.4, not Linux.

I imported my IE 5.2 favorites and pulled the contents of my "Toolbar Favorites"
folder (IE) into my "Personal Toolbar Folder" (Mozilla). After jockeying around
(is the initial reverse-alphabetical sort, correctable by re-dragging the
contents into its own folder, supposed to be a bug or a feature?), I get the
personal toolbar the way I want it, but it never survives a quit.

Another oddity: anything that I had deleted reappears.

Reproducible: Always

Steps to Reproduce:
1.Import favorites from IE
2.Drag contents of "Toolbar Favorites" (IE) into "Personal Toolbar Folder"
3.Reverse-sort by re-dragging PT folder contents into itself
4.Delete a bookmark or bookmark folder
5.Quit & relaunch Mozilla


Actual Results:  
Personal Toolbar is back to its default state, and imported bookmarks are
available but back in the state they were in when first imported, including
deleted items

Expected Results:  
Preserved my changes to Bookmarks and the Personal Toolbar

*** This bug has been marked as a duplicate of 192124 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.