Closed Bug 194919 Opened 18 years ago Closed 18 years ago

keyboard focus stolen when other tab finishes loading

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: warp10, Assigned: jag+mozilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When a page is loading on one tab, and I open a new tab to load another page, if
the first page finishes loading while I'm still typing, it steals the keyboard
focus and sends it to the first tab
It only happens when there is a form on the first tab.

Reproducible: Sometimes

Steps to Reproduce:
1.Begin loading a (slow-loading) page that has a form on it in one tab.
2.Open a new tab, begin typing in address of the new tab's page.
3.When the first tab finishes loading, it steals the keyboard focus (even WHILE
you're typing) and sends it to the form on the first tab.

Actual Results:  
Keyboard focus is pointed at form on first tab

Expected Results:  
Kept keyboard focus on current tab's address bar

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.