After resizing a image, portions of the image's highlight color remain in document

VERIFIED FIXED

Status

Core Graveyard
GFX: Mac
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: Chris Petersen, Assigned: Simon Fraser)

Tracking

({regression, topembed+})

Trunk
PowerPC
Mac OS X
regression, topembed+

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: editorbase)

Attachments

(1 attachment)

7.60 KB, patch
Kathleen Brade
: review+
Brian Ryner (not reading)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Build: 2003-02-24-03
Platform: OS X
Expected Results: Resizing the image should not produce stray artifacts of it's
the its highlight color.
What I got:  After resizing the image, random artifact of the image's highlight
color reamin.


Steps to reproduce:

1) Insert a image in Composer
2) Click on the image to display it's handles
3) Click and drag one of the image's handle to resize the image
4) After resizing the image, notice the artifacts.
(Reporter)

Updated

15 years ago
Summary: After resizing image, portions of the image's highlight color remain in document → After resizing a image, portions of the image's highlight color remain in document
(Reporter)

Comment 1

15 years ago
I can't reproduce this issue under the 2003-02-24-08 Win32 trunk build. Appears
to   be Mac only.
(Reporter)

Updated

15 years ago
Summary: After resizing a image, portions of the image's highlight color remain in document → After manually resizing a image, portions of the image's highlight color remain in document

Comment 2

15 years ago
-->selection
This is a selection issue since I've seen it in browser also.  It isn't
specifically related to resizing but that is the easiest way to see it.

It is Mac-specific.

Simon--did you think this bug should be reassigned to image lib or ?
Assignee: composer → mjudge
Component: Editor: Composer → Selection
Keywords: nsbeta1, regression, topembed
QA Contact: sujay → pmac
Summary: After manually resizing a image, portions of the image's highlight color remain in document → After resizing a image, portions of the image's highlight color remain in document
Whiteboard: editorbase
(Assignee)

Comment 3

15 years ago
This is a bug in the nsImageMac, in the gfx code.
Assignee: mjudge → sfraser
Component: Selection → GFX: Mac

Updated

15 years ago
Keywords: topembed → topembed+
(Assignee)

Comment 4

15 years ago
Created attachment 116390 [details] [diff] [review]
Patch to nsImageMac

This patch fixes a simple logic error (you have to truncate the src/dest if you
are within the last swipe). I also fixed some build warnings by removing unused
variables, and #ifdeffed out some code that isn't needed on OS X, relating to
temporary memory stuff.

Note that I detabbed parts of the file and diffed with -b, so the whitespace
looks off. I'll detab the entire file before checking in.
(Assignee)

Updated

15 years ago
Attachment #116390 - Flags: superreview?(bryner)
Attachment #116390 - Flags: review?(brade)

Comment 5

15 years ago
Comment on attachment 116390 [details] [diff] [review]
Patch to nsImageMac

r=brade but I would like to see topYPos renamed to just topY or change the
others (bottomY, leftX, rightX) to also include "Pos".
Attachment #116390 - Flags: review?(brade) → review+
Comment on attachment 116390 [details] [diff] [review]
Patch to nsImageMac

sr=bryner, though the dstOrigX/Y variables that you removed _are_ used later in
the gtk code that I copied it from; I'm not sure if there's a reason for the
mac code to use these later.
Attachment #116390 - Flags: superreview?(bryner) → superreview+
(Assignee)

Comment 7

15 years ago
Probably not, since the rest of the tiling code is very different. Thanks!
Status: NEW → ASSIGNED
(Assignee)

Comment 8

15 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

15 years ago
Marking verified in the Mach-0 2003-03-21-03 build under 10.2.4.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.