auto clean up (validate) account prefs

RESOLVED DUPLICATE of bug 123027

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED DUPLICATE of bug 123027
15 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

auto clean up bad account prefs

"stale" account prefs have led to at least two bugs, bug #195085 and bug #131384

I'm sure more are logged, or lurking.

before we fix this, I'm hoping we can find a way (by creating / deleting
accounts) to reproduce the this problem.

possible solutions are:

From smaug:
The real problem is following:
I have accounts 2,4,5,6,7,8 in prefs.js.
But the "mail.accountmanager.accounts" includes also accounts 1 and 3.
If I manually remove the account1 and account3 from the
"mail.accountmanager.accounts" I get no errors anymore.

But why the "mail.accountmanager.accounts" includes also
some non-existing accounts?
Is there something wrong with the account removing?


From Smaug:
I looked at the nsMsgAccountManager.cpp and 
I could not find anything wrong when removing accounts.
Maybe this all is just caused by a crash long time ago or something.

But shouldn't we check the validity of "mail.accountmanager.accounts"
values (during startup)?

From neil@parkwaycc.co.uk:
How about scanning the array of accounts for invalid accounts and deleting them
before sorting the array?

cc dan veditz, and he's had some account cruft issues recently, too.
My account cruft was specifically having four duplicate Netscape Webmail
accounts (three of them invisible in the UI), which is likely some old 6.x
commercial registration problem--it's an old profile--and not a Mozilla bug.

Updated

15 years ago
Blocks: 123929

Comment 2

15 years ago
Agree to have the complete removal of accounts. Now, when I compose new mail, I
can still choose my old (and removed) accounts in "From:" list. It is confusing
and I have no method to remove it from UI)
That sounds weird. Maybe there is something wrong in
nsMsgAccountManager.cpp anyway.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 123027 ***
No longer blocks: 123929
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.