RFE: When deleting a message, the following message is then marked read

RESOLVED DUPLICATE of bug 75866

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 75866
15 years ago
13 years ago

People

(Reporter: Seth Master, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

When you delete a message, the next message that is highligheted is marked as read.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Just because it is the next message, and it is now highlighted due to the other
message being deleted, doesnt mean this one should be marked as read.

Comment 1

15 years ago
I believe this is as designed, and not a bug.

Do you mean the expected behaviour is to NOT display the next message in message
body pane when you have deleted the message before it? 

That would imply a lot of clicking in order to read a message. If i got 10 new
mails and wanted to browse and delete them, i would have to click on them 10
times, and click delete as many times.
(Reporter)

Comment 2

15 years ago
No, what I am getting at is just because you deleted the email, doesnt mean the
email that is now displayed, should immediatly marked as read.
Im ok with the fact that it goes to the next message, and the next message is
showed in the "preview pane", but the fact that the next message is
automatically marked as read is not favorable.

If I clicked on an email, 10 messages down, sure, mark it as read, but just
because I was defaulted to this next message, doesnt mean I have read it.
I frequently re-mark my mail as not read, because I havent read it yet, and I
just deleted the message before it.  This happens alot at work since I only mark
a message as read after I have read it, and usually done what ever is being
asked of me as well.

Comment 3

15 years ago
Duping to bug 75866 as a solution for this specific case.  Seth, please comment
in this bug if you disagree.  BTW, if you collapse the preview pane, moving
through the message list won't mark messages as read.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 75866 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.