Closed Bug 19532 Opened 20 years ago Closed 19 years ago

Mark link as visited without reload

Categories

(SeaMonkey :: UI Design, enhancement, P3)

Other
Linux
enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 10491
Future

People

(Reporter: skliaroukp, Assigned: vishy)

References

Details

I have a habit to visit links opening new window (right button+open in new window).

The problem is that these links aren't hilighted as visited on original page.
Assignee: leger → radha
Severity: normal → enhancement
Marking as enhancement and guessing that radha@netscape.com is the right person
for this bug (since there's no component for this type of bug).  I think this is
a good idea, and I wouldn't think it would be to hard to do.
Component: Browser-General → XPApps
QA Contact: leger → claudius
Target Milestone: M20
Setting QA Contact.
*** Bug 22893 has been marked as a duplicate of this bug. ***
*** Bug 23876 has been marked as a duplicate of this bug. ***
Would it be possible to implement this on going back thru history ? E.g. click
on a link, then press the back button, and see the link you pressed marked as
visited. This would be useful in things like FAQ content pages where you click
each link in turn - it's often easy to forget where you got to.
Move to "Future" milestone.
Target Milestone: M20 → Future
*** Bug 50716 has been marked as a duplicate of this bug. ***
nav triage team:

Would be nice, but don't think we'll get to it for beta1, marking nsbeta1-
Keywords: nsbeta1-
Links pointing to an anchor in the currently displayed page (which only scroll
the page) should also be displayed as visited when clicked, not only after reload.
Oops, sorry: bug 30607 already deals with my comment.
Mass moving all Navigator bugs to the Nav team. 
Assignee: radha → vishy
Clicking back should definately show visited links in the correct
colour...otherwise it's a right PITA !
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE

*** This bug has been marked as a duplicate of 10491 ***
I'm not sure if it is a dupe - the other bug's title is '...if opened in
_another_ window'. This one is dealing with eg. clicking a link in _this_ window
and then clicking back or reaload.
Regarding the last comment: the discussion did stray into handling visited
links properly after coming back from a linked page in the same window, but the
original report was clearly on the same topic as bug 10491, "Show link as 
:visited if opened in another window"; VERIFYing.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.