Closed Bug 19548 Opened 20 years ago Closed 20 years ago

Back and Forward don't restore scrollbar position

Categories

(Core :: Layout, defect, P3)

All
Other
defect

Tracking

()

VERIFIED DUPLICATE of bug 16806

People

(Reporter: mikeque, Assigned: pierre)

References

()

Details

Go to above URL.
Scroll to bottom of page.
Click on a link.
After new page loads, click on BACK button to return to original page.
Page loads at top rather than where it was previously scrolled to.

We get a ton of email from HotBot users regarding this bug in current versions.
I've investigated this and this behavior tends to occur with Netscape browsers
(and IE4) whenever the content of the window is displayed using either tables or
css. IE5 does remember the position which I would consider desired behavior.
--Mike
Currently there is no scrollbar memory in Seamonkey (5.0), though it should
appear soon.  Is this a 4.x bug?
It is both a 4.x and M11 bug. -mk
Assignee: leger → pierre
Component: Browser-General → Style System
QA Contact: leger → chrisd
chrisd, can you reproduce?
Assignee: pierre → rickg
Component: Style System → Layout
Summary: Scrollbar memory fails with CSS-P pages → Back and Forward don't restore scrollbar position
I changed the summary line to "Back and Forward don't restore scrollbar position"
from "Scrollbar memory fails with CSS-P pages". This is not a CSS/Style issue. We
probably have a bug to track the problem already but I can't find it. Rick, any
idea?
Is it bug 16806 you are looking for?
QA Contact: chrisd → petersen
Assignee: rickg → pierre
Pierre -- one for you.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
For me? I'm just marking it duplicate as mats said.
Thanks mats!


*** This bug has been marked as a duplicate of 16806 ***
Status: RESOLVED → VERIFIED
Marking as verified dup of 16806.
You need to log in before you can comment on or make changes to this bug.