MacInstaller omits top-level files.

VERIFIED FIXED

Status

P3
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: trudelle, Assigned: jj.enser)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Today's MacInstaller-M12 didn't install any of the top-level files (like the
application).  It did put the Components, chrome, Essential Files, res and
Devaults folders and their contents in place.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 1

19 years ago
Okay, the top-level files appear to be there now.  I don't know why they weren't
showing up before.  I did check that the installer had finished and gave the
Finder a few minutes to catch up, and closed and reopened the folder before
filing this bug.  Resolving as worksforme.
(Assignee)

Comment 2

19 years ago
Actually, the app is probably still missing since it got renamed from 'apprunner'
to 'Mozilla'. I don't know which other top-level file could have been missing.

Fixed xpinstall/packager/packages-mac to include 'Mozilla' in the browser
installer module.
(Reporter)

Comment 3

19 years ago
You don't understand, the install directory had no (zero) files in it for at
least 15 minutes!  I got burned by the name change weeks ago.

Comment 4

19 years ago
Time delay is probably due to the combination of AppleSingle decoding and
updating the desktop db by XPInstall. Although, 15 minutes sounds a little
fishy.

Peter,
I would like to run the installer on your machine once we have a working build
tomorrow (if you could psare the machine for 15-20 mins). Thanks.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

19 years ago
Sure, but you don't need to do it for me.  I run the installer on Mac, and
install on Linux, every working day that you have one, every day on Win98.
I'm reopening & clearing the wfm status, since JJ pointed out that I must have
unstuffed over my installation, that's why the files re-appeared. D'oh!
BTW, why does the installer take so long on the Mac?
(Assignee)

Comment 6

19 years ago
Peter, Grace, is this bug still valid or can we close it?

Comment 7

19 years ago
This was a problem with the binary name changing and the install script aborting
cause it couldn't create an alias (apprunner was no longer being installed:
Mozilla was), I believe.

At any rate, it was fixed by changes I made to the install script around a week
ago. I think it is safe to close it unless others say otherwise.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
This has been fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
build 1999121308
(Assignee)

Comment 10

19 years ago
cc'ing Alan Masri who apparently observed this bug with yesterday's build (12/13)
Alan & Samir, did you figure out what happened ? Should this bug be reopened ?

Comment 11

19 years ago
No, as I mentioned to Allan a new bug should be opened. The
top-level-files-not-being-nstalled symptom is commonly observed when something
goes wrong and browser.xpi is not installed or not downloaded. The cause can
from multiple parts of the install process and hence we need to distinguish them
as distinct bugs so I can fix them and QA can verify them individually.

Allan, as we discussed yesterday feel free to log a bug against me about the
problem on the Japanese version of Mac OS 8.5 that we observed. Thanks.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.