Unable to call Java function in Applet from JavaScript

RESOLVED DUPLICATE of bug 97613

Status

--
major
RESOLVED DUPLICATE of bug 97613
16 years ago
8 years ago

People

(Reporter: cc, Assigned: beard)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

Unable to call Java function in Applet from JavaScript. When attempting a call
from JavaScript to Java nothing happens. Setting a breakpoint in the JavaScript
functions show that the JavaScript function *is* called, but the Java function
in the applet is not called. 

Reproducible: Always

Steps to Reproduce:
1.Unzip the test case Zip file
2.Open the "testCase.html" file in Mozilla 1.3b
3.Click the "Start" button
4.Observe that no "Hello World..." text is output to the Java Console.
5.Repeat the same test for Mozilla 1.2.1 and observe the correct behaviour

Actual Results:  
No "Hello world..." output to Java Console

Expected Results:  
Produced "Hello world..." output to Java Console as a sign of calling the Java
funtion in the Java applet
(Reporter)

Comment 1

16 years ago
Created attachment 116089 [details]
Zip-archived testcase

Updated

16 years ago
Attachment #116089 - Attachment description: Testcase for reproducing bug. See description of bug report → Zip-archived testcase
Attachment #116089 - Attachment mime type: application/octet-stream → application/zip

Comment 2

16 years ago
Christer, do you see the warnings and error sent to the JS Console by your testcase?

Comment 3

16 years ago
This belongs in the OJI component; reassigning -
Assignee: rogerl → joshua.xia
Component: JavaScript Engine → OJI
QA Contact: pschwartau → dsirnapalli
(Reporter)

Comment 4

16 years ago
I get this output in the Java console of 1.2.1 and 1.3b when running the testcase. I do *not* get any output in the JavaScript console.Output below:--------------------------------------------------------------------------------Mozilla 1.2.1<<< ProxyClassLoader: defined LiveConnectProxy class. >>><<< Here're the permisssions you've got: >>><<< java.security.Permissions@29255c ( (java.util.PropertyPermission java.vendor read) (java.util.PropertyPermission java.specification.version read) (java.util.PropertyPermission com.apple.macos.useScreenMenuBar read,write) (java.util.PropertyPermission line.separator read) (java.util.PropertyPermission java.class.version read) (java.util.PropertyPermission mrj.version read) (java.util.PropertyPermission java.specification.name read) (java.util.PropertyPermission java.vendor.url read) (java.util.PropertyPermission java.vm.version read) (java.util.PropertyPermission os.name read) (java.util.PropertyPermission os.arch read) (java.util.PropertyPermission os.version read) (java.util.PropertyPermission java.version read) (java.util.PropertyPermission java.vm.specification.version read) (java.util.PropertyPermission java.vm.specification.name read) (java.util.PropertyPermission java.specification.vendor read) (java.util.PropertyPermission java.vm.vendor read) (java.util.PropertyPermission file.separator read) (java.util.PropertyPermission path.separator read) (java.util.PropertyPermission com.apple.hwaccel read,write) (java.util.PropertyPermission java.vm.name read) (java.util.PropertyPermission java.vm.specification.vendor read) (java.net.SocketPermission localhost:1024- listen,resolve) (java.lang.RuntimePermission stopThread) (java.lang.RuntimePermission accessClassInPackage.sun.audio) (java.io.FilePermission  read)) >>>--------------------------------------------------------------------------------Mozilla 1.3bDuplicate key in parameter table: width using the htmlAttribute.	 first: 100	second: 100			

Comment 5

16 years ago
Mac -> beard@netscape.com
Assignee: joshua.xia → beard

Comment 6

16 years ago
Using FizzillaMach/2003030503, clicking Start in the testcase generates 11 of
this warning (full path to source file edited for privacy):

Warning: reference to undefined property document.Jaconomy.helloWorld
Source File: testCase.html
Line: 6

and 1 of this error:

Error: document.Jaconomy.helloWorld is not a function
Source File: testCase.html
Line: 6

on the JS Console.

Comment 7

15 years ago
OS: Redhat 9.0 - Linux 2.4.20 - Blanes 2000 Window Manager 
MOZILLA: Mozilla 1.4 - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030529


I am experiencing the same bug at this page (Brazil Bank):
https://www2.bancobrasil.com.br/aapf/aai/login.pbk

The applet can't be reached in javascript. The error message at JS Console is:
>Error: document.applets.tclJava.setFocus is not a function
>Source File: https://www2.bancobrasil.com.br/aapf/includes/formatadadosns2.js
>Line: 122

This error happened when I pressed the TAB key to move focus to the applet or
when I click the mouse on the applet.

Sometimes when I open a new Window from the Menu (File/New/Navigator Window) and
come back to the page, I can set the focus to the applet and everything works
fine, without errors in JS Console.

P.S: The same problem is reproducible on this platform with Mozilla 1.4 and
1.2.1

Comment 8

15 years ago
http://www.mozilla.org/releases/mozilla1.3.1/
  The MRJ Java plugin is not available in Mozilla 1.3.1 on OS X, so
  LiveConnect does not work. Mozilla will use Apple's Java Applet plugin,
  if available, to display applets.

*** This bug has been marked as a duplicate of 97613 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.