Table height of 100% ignored when table inside a form

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: Oliver Jonas, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

The example URL shows the incorrect behaviour and has a link to the same page 
with the form commented out in which case the page displays fine.

Reproducible: Always

Steps to Reproduce:
This is a duplicate
Whiteboard: DUPEME

Comment 2

15 years ago
Hmm, dupe of bug 10212?

Comment 3

15 years ago
*** Bug 204937 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
The table occupies the whole browser window, when the form element is styled
with height:100% . This may serve as a workaround for web page authors.
This might be a dupe of bug 41656. See the discussion at bug 113222.
*** Bug 215111 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
URL works fine (ie, table occupies the whole page) in mozilla1.0.2. this is a
regression 

Comment 7

15 years ago
For web page developers: 

  <form style="height:100%">

should only be used in Mozilla/Netscape. In some IE versions
we got strange results.

Comment 8

15 years ago
will this help confirm it ?
<html>
<head>
<title></title>
</head>
<body>
<!-- adding style="height: 100%" to FORM element fixes problem -->
<form>
<table width="100%" height="100%">
<tbody>
<tr>
<td width="100%" height="100%"> <iframe id="frame1_id"
width="100%" height="100%"
style="background: green none repeat scroll 0% 50%; -moz-background-clip: 
initial; -moz-background-origin: initial; -moz-background-inline-policy: 
initial;">
</iframe> <br>
</td>
</tr>
</tbody>
</table>
</form>
</body>
</html>

Comment 9

15 years ago
this works now as a result of the checkin for bug 222730
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.