Japanese text is displayed in Chinese font

VERIFIED FIXED

Status

()

Core
Internationalization
--
blocker
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: Koike Kazuhiko, Assigned: smontagu)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Japanext text is displayed in Chinese font.

2003022709-trunk/Linux doesn't have this bug. The builds after that
are totally unusable.
(Reporter)

Comment 1

15 years ago
Created attachment 116126 [details]
Screenshot

Updated

15 years ago
Keywords: nsbeta1
(Assignee)

Comment 2

15 years ago
Jungshik, could this be related to your checkin on bug 180851? I don't see
anything else likely in the timeframe where this regressed.
(Reporter)

Updated

15 years ago
Summary: Japanext text is displayed in Chinese font → Japanese text is displayed in Chinese font

Comment 3

15 years ago
It might as well be especially because my check-in was incomplete in the sense that
configure.in that I checked in had a flaw that made converters for X11 font
encodings NOT built _even_ for Mozilla-X11 build. I've been waiting for
alecf's sr for the fixed configure.in, but since seawood is the ultimate
authority on 
the Mozilla build system, I guess I can go ahead checking it in with seawood's
review.
What would you say? 

On the other hand, my patch for bug 180851 might  not be the cause. I'll do some
more experiments.

 
(Assignee)

Comment 4

15 years ago
http://www.mozilla.org/hacking/reviewers.html says "cls@seawood.org is the
autoconf module owner for Unix, OS2, and other gmake-friendly platforms. His
review is sufficient to get changes to those files checked in; staff@mozilla.org
require no extra review here."

Please check in the additional patch to configure.in.

Comment 5

15 years ago
Thanks. I should have known that. anyway, fix for configure.in has just been
checked in.
 
Depends on: 180851

Comment 6

15 years ago
Sorry for the regression I introduced. Fortunately, this is now fixed.

I'm now running 2003-03-04-15 nightly and it does not have  this problem 
any more. Mozilla.gr.jp and Yahoo Japan are rendered with all Japanese
glyphs from JIS X 0208 fonts.
Mozilla does respond to changing Japanese fonts(that require
converters not included in 02-28 to 03-03 nightlys) in font-pref.  
(Reporter)

Comment 7

15 years ago
2003030415-trunk/Linux works fine.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

15 years ago
Verifed as fixed in current trunk.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Keywords: nsbeta1 → nsbeta1+
You need to log in before you can comment on or make changes to this bug.