Status

VERIFIED DUPLICATE of bug 175292
16 years ago
10 years ago

People

(Reporter: joe, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Copy&paste from jakarta james ml:

It looks like a mozilla bug.

This seems to be as per the 1738 

>> nntp://www.vrspace.org/org.vrspace.dev/1


but Mozilla has this interaction:
-------
S: 200 vr NNTP Service Ready, posting permitted
C: MODE READER
S: 200 Posting Permitted
C: GROUP org.vrspace.dev/1
S: 411 no such newsgroup
-------

This is incompatible with nntp rfc GROUP command.
format should be GROUP <name>


Btw. IE 6.0 also has a bug.
for the same URL it has this interaction:
-------
S: 200 vr NNTP Service Ready, posting permitted
C: MODE READER
S: 200 Posting Permitted
C: ARTICLE <1>
S: 430 no such article
-------

This breaks nntp rfc ARTICLE Command
format should be 
             ARTICLE <message-id> 
             ARTICLE [number] 
IE seems to be sending ARTICLE <number>


Harmeet

----- Original Message ----- 
From: "Josip Almasi" <joe@vrspace.org>
To: <james-user@jakarta.apache.org>
Sent: Monday, March 03, 2003 9:12 AM
Subject: NNTP URL?



>> Hi,
>> 
>> I have James 2.1.2 with one test newsgroup:
>> news://www.vrspace.org/org.vrspace.dev
>> 
>> and one article:
>> news://www.vrspace.org:119/31912175.1046506760868.0%40vrspace.org
>> 
>> There's one item in apps/james/var/nntp/articleid, org.vrspace.dev=1.
>> As specified in rfc1738, nntp url should be
>> nntp://www.vrspace.org/org.vrspace.dev/1
>> right?
>> 
>> But when I click on this link, Mozilla 1.3a asks 'do you want to 
>> subscribe to org.vrspace.dev/1'.
>> 
>> 

Reproducible: Always

Steps to Reproduce:
Type nntp url in location, i.e.
nntp://www.vrspace.org/org.vrspace.dev/1
Actual Results:  
'do you want to subscribe to org.vrspace.dev/1'.

Expected Results:  
open article #1 in org.vrspace.dev newsgroup from www.vrspace.org host

Well this bug is already reported, with less details.
I wanted to confirm it, but clicking in search above resulted in 
The requested URL /confirmhelp.html was not found on this server.
:))

Comment 1

16 years ago
Duplicate of bug 175292

*** This bug has been marked as a duplicate of 175292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.