Presence of certain accented characters causes text to render improperly.

RESOLVED DUPLICATE of bug 182650

Status

()

RESOLVED DUPLICATE of bug 182650
16 years ago
16 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030303
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030303

For the most part, it seems to be finding the accented characters on a line,
rendering those and ignoring everything else after the first one. Highlighting
certain letters causes the correct render to show up, but only to the next
accented character. I don't know if this happens on all accented characters, I
noticed it first on those lesson pages. Lesson 6 shows the most errors.

Reproducible: Always

Steps to Reproduce:
1. Viewed page with Esperanto accents. (Not sure if the Esperanto-ness matters.)
2.
3.

Actual Results:  
Incorrect rendering of text.

Expected Results:  
Rendered the text correctly.

I'm running Debian sid, with freetype enabled.
(Reporter)

Comment 1

16 years ago
The same effect can be seen here happening with the Euro symbol:

http://www.debianplanet.org/node.php?id=918
Are you using an Xft build?  If so, this may be a duplicate of bug 182650, which
is an X bug, not a Mozilla bug.  (See bug 182650 comment 9.)
(Reporter)

Comment 3

16 years ago
I think it uses Xft2, not sure though.

However, I don't think it's related to bug 182650. I went to the page pictured
in the screenshot there and it renders fine. (Not sure why that is, exactly.)

Let me get a screenshot of the rendering problem as I see it.
(Reporter)

Comment 4

16 years ago
Created attachment 116768 [details]
Shot of rendering problem.

You can see where I've highlighted the u-breve, without highlighting that, all
the text between it and the next g-circumflex is removed, and the u-breve and
g-circum are right next to each other. (I can highlight the next char to get
the next section, but the previous text disappears (although the space for it
remains)).
The bug only shows up on the original URL if you explicitly set the character
encoding to UTF-8 rather than iso-8859-2.

*** This bug has been marked as a duplicate of 182650 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.