configure should not use libdl on OS X [/usr/lib/libdl.0.dylib]

VERIFIED FIXED

Status

SeaMonkey
Build Config
--
blocker
VERIFIED FIXED
15 years ago
7 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Bug Flags:
blocking1.3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed1.3)

Attachments

(1 attachment)

490 bytes, patch
hacker formerly known as seawood@netscape.com
: review+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
configure currently tests for the presence of libdl (containing dlopen) and adds
it to OS_LIBS unconditionally if it's found.  This should be disabled on Mac OS
X -- we don't use dlopen functionality for anything on OS X, and if the build
machine has libdl, it will create a build that a stock OS installation (without
libdl) won't be able to run.

Comment 1

15 years ago
1.3 branch builds are totally broken because of this problem. We need this for
1.3. Bryner, how long will this take to fix? Can you make it a priority?
Flags: blocking1.3+

Comment 2

15 years ago
*** Bug 195723 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Severity: normal → blocker
Keywords: crash
Summary: configure should not use libdl on OS X → configure should not use libdl on OS X [/usr/lib/libdl.0.dylib]

Comment 3

15 years ago
Asa,
another fix that *might* be sufficient for 1.3 given the schedule is to remove
that lib if it's present on the build system.
To be honest, I have no idea how it got there, but I removed it yesterday and
today's build doesn't crash for me anymore.

I agree that we should have it fixed in configure, but in the meantime we *DO*
have an OSX candidate build out for 1.3

Comment 4

15 years ago
OK, let's try to get this fixed for 1.3. If we have everything else fixed and
this doesn't make it then we should add a note to the build instructions for 1.3
letting people know how to work around the problem.
(Assignee)

Updated

15 years ago
Attachment #116479 - Flags: review?(seawood)
Comment on attachment 116479 [details] [diff] [review]
patch

You might want to add a comment explaining why we're skipping that check. 
Other than that, r=cls
Attachment #116479 - Flags: review?(seawood) → review+

Comment 7

15 years ago
Comment on attachment 116479 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to 1.3.  We need this landed ASAP.
Attachment #116479 - Flags: approval1.3+

Updated

15 years ago
Whiteboard: fixed1.3
(Assignee)

Comment 8

15 years ago
checked into the branch and the trunk, with a comment in there about why.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.