All users were logged out of Bugzilla on October 13th, 2018

crash when I press the send button

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: ifinci, Assigned: mscott)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030305
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030305

When ever I try to send an email - mozilla immidiatly crashes. 
This happens only with this nightly, not with older versions (1.3b or evern 1.4a
nightly from few days back).

Reproducible: Always

Steps to Reproduce:
1.write a short email
2.press the send button
3.

Actual Results:  
mozilla crashes.

Expected Results:  
send email.
(Reporter)

Comment 1

16 years ago
well - I've done some more checking - this happens only if the spell checker is
enabled (I have the one from spellcheck.mozdev.org installed).

Agian - I don't see this with older versions even when the spell checker is on.

Comment 2

16 years ago
can you post Talkback ID for this crash "mozilla/bin/components/talkback/talkback" ?
Did you check http://spellchecker.mozdev.org/installation.html#mozilla1.4a and
running latest version of spellchecker ?
Keywords: crash, stackwanted
(Reporter)

Comment 3

16 years ago
I've checked the 1.4a spell checker installation.
As for talkback - how to I get this?

Comment 4

16 years ago
when mozilla crashes, it should give you a window where you can fill in
email/url/comments and then "send".  After you do that, run
mozilla/components/talkback/talkback, note the talkback for the crash you sent
in and report that here.
(Reporter)

Comment 5

16 years ago
Well - it doesn't open the talkback window at all.
I've ran mozilla from a console, and noticed the following error when it crashed:

software/mozilla-030305/mozilla-bin: relocation error:
ifinci/software/mozilla-030305/components/libspellchecker.so: undefined symbol:
CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv

The crash happens due to the spellchecker for sure, since it happens when
pressing the spell button also.

bye,
Ilan

Comment 6

16 years ago
Ilan:  If a window did not popup when you crashed, you do not have a Talkback
enabled build.  Could you please download a Talkback enabled build, reproduce
this crash again and send in the incident?  Thanks.

If he is using the latest spellchecker, I wonder how different it is from the
crashes mentioned in bug 185251.

Comment 7

16 years ago
> software/mozilla-030305/mozilla-bin: relocation error:
> ifinci/software/mozilla-030305/components/libspellchecker.so: undefined symbol:
> CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv

talkback won't catch that.  Mozilla will "abort" in that situation which
bypasses the talkback mechanism.

It is mostly likely that Mozilla changed some API and the spellchecker folks
have not compiled a new version (note that the linux version is from mid-February).

Comment 8

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.5) Gecko/20030925

I have also seen this problem 3 times without spell checker activated. On two
occasions I sent a talkback. On one occasion, I know that the message was
properly sent, but it was not moved to my sent messages before the crash. There
is nothing I can say that was common to all three instances. Two were replies to
multiple parties, one was to a single person (not sure if it was a reply or not,
it included none of the original message if it was). Let me know if you would
like any more information

Comment 9

15 years ago
This is 1 of 2 talkback incidents under Jon Scharff's email address.  Other than
the comment section, the 2 stack traces are identical.

Incident ID 24936759
Stack Signature 	FULLSOFT.DLL + 0x111a (0x60dc111a) fe0ee95b
Product ID 	MozillaTrunk
Build ID 	2003092514
Trigger Time 	2003-10-30 07:50:03
Platform 	Win32
Operating System 	Windows NT 5.0 build 2195
Module 	FULLSOFT.DLL
URL visited 	
User Comments 	sending mail
Trigger Reason 	Access violation
Source File Name 	
Trigger Line No. 	
Stack Trace 	
FULLSOFT.DLL + 0x111a (0x60dc111a)
FULLSOFT.DLL + 0x1285 (0x60dc1285)
FULLSOFT.DLL + 0x73af (0x60dc73af)
msafd.dll + 0x6273 (0x74fd6273)
msafd.dll + 0x8d4f (0x74fd8d4f)
msafd.dll + 0x4c6a (0x74fd4c6a)
WS2_32.DLL + 0xc21d (0x7503c21d)
_PR_MD_CONNECT [c:/builds/seamonkey/mozilla/nsprpub/pr/src/md/windows/w95sock.c,
line 147]
SocketConnect [c:/builds/seamonkey/mozilla/nsprpub/pr/src/io/prsocket.c, line 277]
Ipv6ToIpv4SocketConnect [c:/builds/seamonkey/mozilla/nsprpub/pr/src/io/pripv6.c,
line 136]
ssl_DefConnect [c:/builds/seamonkey/mozilla/security/nss/lib/ssl/ssldef.c, line 57]
ssl_Connect [c:/builds/seamonkey/mozilla/security/nss/lib/ssl/sslsock.c, line 1101]
nsSSLIOLayerConnect
[c:/builds/seamonkey/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp, line 881]
nsSocketTransport::InitiateSocket
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsSocketTransport2.cpp, line 938] 

Comment 10

14 years ago
what I said in comment 7 was correct and the original bug is no longer a problem

Jon: if you still crash, please file another bug

resolving WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.