double-click highlights more than than what it is indicated !

VERIFIED DUPLICATE of bug 98546

Status

()

Core
Selection
VERIFIED DUPLICATE of bug 98546
15 years ago
15 years ago

People

(Reporter: Helder Mendes, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; T312461)
Build Identifier: Mozilla/5.0 (X11; U; OpenVMS US; rv:1.2.1) Gecko/20030214 SWB/V1.2.1 (HP), build 2003021414 

This is the instruction:
For the following words preceeded or followed by a non-alpha character, only 
the word "foo" should be highlighted upon a double-click: 
foo- 
foo? 
foo... 

But when you double-click on "foo... " everything is highlighted, even the "..."

The following two-word pairs, concatenated by a non-alpha character, should 
only be highlighted as individual words upon a double-click. (e.g. "foo" 
or "bar") 
foo/bar 
foo=bar 
foo_bar 
bar&grill 

Same thing here: what is highlighted is "foo/bar " instead of "foo"

Reproducible: Always

Steps to Reproduce:
1.Click on http://www.mozilla.org/quality/browser/front-
end/testcases/selection/double-click-text/double-click-text-d.html 
2. Click on this link double-click-text.html 
3. Double click on "foo... " or "foo/bar "


Actual Results:  
Text and non-alpha character is highlighted. I saw this on Mozilla/SWB OpenVMS 
Version. I couldn't see this on Linux because I could find any written text for 
it.
But this works in Windows NT. I mean, double-clik on "foo/bar " pair not 
Mozilla for Windows NT.


Expected Results:  
Only "foo" should be highlighted !

Comment 1

15 years ago
I see the same behaviour with Netscape 7 on Windoze. I think the test is wrong.
OS: other → All
Hardware: Other → All

Comment 2

15 years ago
Reporter: The behaviour under 2003030504 / XP seems correct to me.

Note that what is highlighted changes based on *where* you double-click.

For example, if I double click on any of the letters in "foo..." only "foo" is
highlighted.  It's only when I double-click on the whitespace between "o" and
"." that everything is highlighted.  (Which is also, BTW, what happens when I
double click between "o" and "-" - all of "foo-" gets highlighted.) Also note
that when you double-click on one of the non-alpha characters, only the
non-alpha characters gets highlighted, not the whole word.

So not only do I not see any inconsistency here but it makes sense.

Comment 3

15 years ago
Mozilla 1.2-1 on Redhat.

If I double click on any of the letters in "foo..." everything, including the
dots, is highlighted.
(Reporter)

Comment 4

15 years ago
Ok, I see the same thing on Linux/Mozilla r:1.2.1 Gecko/20021130

Comment 5

15 years ago
We should really be basing this bug on what the current trunk builds do...

Comment 6

15 years ago
> We should really be basing this bug on what the current trunk builds do...

Agreed. I suggest we close this bug report as Helder is testing a browser which
is based on Mozilla 1.2-1 (the latest "released" version), and I think we all
agree that OpenVMS matches the Linux behaviour on 1.2-1.

Comment 7

15 years ago
I see the same "foo" problem on my minutes old cvs Linux build.

Comment 8

15 years ago
this issue is addressed in bug 98546 which was already fixed; try a newer build
to check it;
Actually, the real issue is that stop_at_punctuation is _false_ on Unix.  See
http://lxr.mozilla.org/seamonkey/source/modules/libpref/src/unix/unix.js#78

See discussion in bug 98546 on this (bug 98546 comment 101 and on).

*** This bug has been marked as a duplicate of 98546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 10

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.