browser crash upon opening page

RESOLVED DUPLICATE of bug 92425

Status

()

Core
Document Navigation
--
critical
RESOLVED DUPLICATE of bug 92425
16 years ago
16 years ago

People

(Reporter: Will Taylor, Assigned: Adam Lock)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

The page at http://www.aria-nightclub.com/ crashes the browser.  It comes up and
flashes for a second, then crashes.  The page is a mostly a javascript broser
check that pops up a new window.

Reproducible: Always

Steps to Reproduce:
1. Using Mozilla 1.3b 2003021008 bring up this url http://www.aria-nightclub.com/
2. Watch the browser crash
Actual Results:  
Browser crash

Expected Results:  
Display the page and then pop up a new window
(Reporter)

Comment 1

16 years ago
Created attachment 116422 [details]
Browser crash test case

This is the source of the page that crashes the browser

Comment 2

16 years ago
wfm using build 2003030408 on Win2k + Flash 6.0r65.
Can you post Talkback ID for this crash "mozilla/bin/components/talkback.exe" ?
Assignee: rogerl → peterlubczynski
Component: JavaScript Engine → Plug-ins
Keywords: crash, stackwanted
QA Contact: pschwartau → shrir
(Reporter)

Comment 3

16 years ago
I have no Talkback ID...it isn't capturing the crash.  I just checked and I have
Talkback turned on, but no dice.  Suggestions?  Anything else I can do to help?

Comment 4

16 years ago
Created attachment 116425 [details]
Minimal example

This is a minimal example of this bug

Comment 5

16 years ago
I have just created and attached a minimal test example.
I get the same problem (browsers closes, no talkback)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

Comment 6

16 years ago
Catching this bug has proved very hard. By running multiple web pages, and
entering random bits of other (nice simple valid) HTML into the minimal example
I can occasionally cause a crash. Such an example is at TB17795193W

Comment 7

16 years ago
Created attachment 116441 [details]
stack from MSDEV for last testcase

Here's the stack for that last testcase from msdev. It's a bit different than
what talkback reports and you can see the recursion better. I think this may be
another dup of bug 92425.

Comment 8

16 years ago
-->docshell
Assignee: peterlubczynski → adamlock
Status: UNCONFIRMED → NEW
Component: Plug-ins → Embedding: Docshell
Ever confirmed: true
QA Contact: shrir → adamlock
(Assignee)

Comment 9

16 years ago
Duping against bug 92425. Obviously something has changed recently which has
caused this regression.

*** This bug has been marked as a duplicate of 92425 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.