entire browser window including menu items fails to refresh after extended use with multiple windows open (GDI leak)

VERIFIED DUPLICATE of bug 204374

Status

defect
--
blocker
VERIFIED DUPLICATE of bug 204374
16 years ago
10 years ago

People

(Reporter: scphantm, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030306
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030306

i have an Nvidea gForce2 MX AGP card and an ATI Rage IIC PCI card im my system.
 the gForce is the primary card.  When i use mozilla for browsing to many
different web sites in a short period of time with multiple copies open at the
same time, it eventually will fail to refresh the screen.  This is a low level
graphics problem because it will also fail to refresh the menu bar.  the way the
screen will work when the graphics crashes is i will open an new window and i
will get the sizable outline of the window with the maximize and minimize
buttons and such, but the center of the window will be just a snap of the stuff
behind it.  so im my mozilla window i will have my background image.   i can
take that window and drag it all over the screen and it will stay the same snap
of the background image.  if i grab a scroll bar and scroll up and down the
browser window, the web page i am looking at will refresh and show the info that
was below the main screen and  when i scroll back to the top of the web page it
will show the top of the screen.  once this happens once, it affects all open
browser windows and does not stop until i completely restart mozilla.  

while it is crashed, if i brows to another web page, it will go to the page,
download the html, but not render it to the screen until i scroll down with the
scroll bar as i have said above

Reproducible: Always

Steps to Reproduce:
1.  configure a system with 2 monitors
2.  browse repeatedly with multiple windows
3.  eventualy it will happen

Actual Results:  
the graphics system eventually crashes

Expected Results:  
just display the page normaly and move the menu bar

Comment 1

16 years ago
The same situation happens on matrox g550 dual head. I'm not sure if it depends
on multiple windows. I just noticed, that I can't use it longer than 15 minutes
to get that error. Quitting mozilla helps. For another 15 minutes :-( It happens
with all windows, not only browser -- I used to use Mail window on the second
screen and it spoils, too.

Comment 2

16 years ago
The longer I use it, the worse it looks. It even influences other applications.
Agfa SnapScan shouts "Failed to create empty document" (I'm not so sure if it is
because of mozilla, but looks like that), M$ SQL Enterprise Manager looses icons
or even crashes, some utility programs crash with strange messages, some behave
similary to mozilla -- lose ability to refresh itself. some programs can't set
themselves "on top", menu "Start" doesn't show at all. An all that happens until
"broken" mozilla is open. After closing it everything usually works properly.
"Usually", because I was even forced to restart the system once.
Pls do something, I suffer from using IE/Opera :)

Comment 3

16 years ago
My experience with this bug is that if I keep one or several Mozilla window(s)
open for more than 2-3 days, this bug will occur.  The browser window(s) will
fail to refresh and ALL Mozilla windows have to be closed in order to be able to
use the browser again.  I am using a PC running Win2000 5.00.2195 SP3.  I am
using Mozilla 1.4a.  Thanks for looking into this!

Comment 4

16 years ago
Same here, I have a matrox g550, too, but the second head is completelly disabled.
I'm using Mozilla Firebird and it only happens to me when i open a large amount
of windows in tabs and work with them for a few minutes. Closing mozialla only
fixes the problem for a few minutes and not completely (It still appears
immediatelly after restart mozilla when pressing F11 for fullscreen). To
completelly fix it, i have to reboot my system. Again with 4-5 Tabs it works
great, but when opening 20 or so and working a few minutes with it messes up
completely.

It has something to do with the size of the window, when it occurres it helps to
make the windows smaller, it's gone then untill it occurres next, then i can
make the mozilla window smaller again it and it's gone for another few minutes -
i end up with a window that is to small to work in =)

I'm using Win2k Server with all avaiable updates, DirectX9a, latest grafik
driver and bios.
This will probably be a duplicate of one of the GDI leak bugs, although working
out which one will require exact steps to reproduce.
Summary: entire browser window including menu items fails to refresh after extended use with multiple windows open → entire browser window including menu items fails to refresh after extended use with multiple windows open (GDI leak)

Comment 6

16 years ago
if that helps anything, i can provide remote access to affected systems to
install debuggers or anything you need to track it down. in case you have access
to systems with matrox g400 or g550 card, i'll try to find the fastest way to
100% reproduce this. it seems that it is easer to trigger that bug on matrox
cards than on other cards for some reason and there was some discussion about it
in the matrox tech support forums (with no result).

Comment 7

16 years ago
I'm wondering if it's only a mozilla bug or rather matrox one (or maybe anything
else)? I have no big clues, but I'm using mozilla very rarely since it started
to break but I still have big problems with other applications!

I don't mean I don't use mozilla -- I have to use it at least once per 2 hours
-- I need its mail program (this is the best one I know :), but only for
necessary time -- no longer and sometimes even shorter (when I need to save a
draft and  restart mozilla and other applications to "clean" their windows)

It looks like it depends the most on windoze 2k/xp feature "window transparency"
(I'm using it in Miranda IM and Quintessential player) and applications' skins
(as mozilla or avant browser have), but this is the only trace I found..

Comment 8

16 years ago
> It looks like it depends the most on windoze 2k/xp feature "window transparency"
(I'm using it in Miranda IM and Quintessential player) and applications' skins
(as mozilla or avant browser have), but this is the only trace I found..

That was one of my first guesses, too:

http://forum.matrox.com/mgaforum/Forum9/HTML/010879.html
(nick g0a)

...but it can't be a 'matrox bug', because users with other cards seem to have
simmilar problems.

it can only be a bug in gdi or in mozilla, even if it's more visible on matrox
cards for some reason.

as stated in post above, i have problems with other apps as well, but the
'source' still seems to be mozilla, because it only appears when i started
mozilla at least one time after a clean boot.

however, what can we do to track this down?

i'm a stupid php coder, all i can do is provide remote access or provide steps
to reproduce:

as said, i'm using mozilla firebird (with advanced tab extension and coffe
theme). the steps to reproduce are simple:

just open a huge amount of sites in tabs (20-40), work a few minutes with them
(10-20 minutes) and change the size of the window from time to time and press
f11 fullscreen from time to time (it's first visible in fullscreen mode).

Comment 9

16 years ago
*** Bug 204075 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
This is also happening to me -- see my comments in bug 204075. I'm using an
Nvidia Riva TNT2 card.

This is the most serious bug I've run into with Mozilla in a long time. I have
to restart Mozilla every couple hours. It's making it practically unusable.

Comment 11

16 years ago
This bug is definitely related, in some way, to bug 204374, which has an
extensive series of comments.  I've voted for a host of GDI-related bugs because
I think these are all fundamentally the same issue and I want, very desperately,
for the problem to go away.

Comment 12

16 years ago
More activity at duplicate bug 204374.

*** This bug has been marked as a duplicate of 204374 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.