Closed Bug 196199 Opened 19 years ago Closed 19 years ago

Downloaded file has permissions from temp directory, instead of directory being downloaded to

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124307

People

(Reporter: mark, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When one downloads a file, the permissions set on the file are that of the
user's temp directory, instead of the directory the file is actually being saved to.

For instance, my temp directory allows only myself and system to access the
files.  So when I save to a "common" directory, other users can't access the
file.  I have to manually change the permissions on the file, after I download it.

Reproducible: Always

Steps to Reproduce:
1. Ensure your temp directory to something restrictive (by default in XP, it is
 just you and System)
2. Create a directory with permissions that allow others to access its contents.
(Must be on same drive as temp directory)
3. Download a file to this directory.

Actual Results:  
Permissions on file are those of the temp directory.

Expected Results:  
It seems reasonable that the permissions on the file should be those of a file
created within the target directory.

*** This bug has been marked as a duplicate of 124307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.