Changing Filter Criteria Ignored

RESOLVED DUPLICATE of bug 196430

Status

RESOLVED DUPLICATE of bug 196430
16 years ago
10 years ago

People

(Reporter: david, Assigned: naving)

Tracking

Trunk
Other
AIX

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; AIX 000D86BD4C00; en-US; rv:1.4a) Gecko/20030306
Build Identifier: Mozilla/5.0 (X11; U; AIX 000D86BD4C00; en-US; rv:1.4a) Gecko/20030306

On any existing or new filter, changing criteria is ignored and
remains as 'Subject'.

Changing in msgFilterRules.dat file results in filter being disable.
Upon trying to enable message - This filter was probably created by a
future version of mozilla/netscape. You cannot enable this filter
because we don't know how to apply it.

Reproducible: Always

Steps to Reproduce:
1. Create new or edit existing mail filter
2. Click on criteria an select new criteria, different than Subject
3. Release popup and Subject remains
4. Maually modifying rule by hand editing disables rule indefinitely
Confirmd 2003030608-trunk/Win-Me and 2003030908-trunk/Win-Me with Modern theme
or Orbit Retro 1.2 0.0.7 theme.
When adding condition by "More" button, criteria becomes same as last one and
changing of this criteria was ignored.

Work around 1: Use theme whose criteria field is text box(such as Classic theme)

Work around 2: Edit msgFilterRules.dat and change conditions manually.
 For example;
 condition="OR (subject,is,Subject-Text1) OR (subject,is ,Subject-Text2)"
 => 
 condition="OR (sender,is,abc@def.hij) OR (to,contains,abc@def.hij)"

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 196430 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.