The default bug view has changed. See this FAQ.

Export the function that lets an app add OIDs dynamically.

RESOLVED DUPLICATE of bug 124923

Status

NSS
Libraries
P2
enhancement
RESOLVED DUPLICATE of bug 124923
14 years ago
13 years ago

People

(Reporter: Javier Delgadillo, Assigned: Nelson Bolyard (seldom reads bugmail))

Tracking

3.10
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

14 years ago
There is a funciton in NSS, SECOID_AddEntry which was designed to allow
applications to add OID's to NSS table of OID's.  The function is not exported.

Exporting the function would make it possible for applications to add OID's that
NSS doesn't know about.

Comment 1

14 years ago
Created attachment 116588 [details] [diff] [review]
Export AddOid. Fix AddOid to be useful.

This patch is for NSS 3.8

Comment 2

14 years ago
Created attachment 117087 [details] [diff] [review]
SEC_AddOidEntry should return SECOidTag, not SECStatus.

Nelson caught this, not the Windows compiler. Note the function was returning a
SECOidTag even though it was declared to return a SECStatus. SECStatus is an
enum, not an int, so the compiler is getting to agressive in it's implicit
casting...
Attachment #116588 - Attachment is obsolete: true

Comment 3

14 years ago
Setting target to NSS 3.8
Target Milestone: --- → 3.8

Updated

14 years ago
Attachment #117087 - Flags: superreview?(nelsonb)
Attachment #117087 - Flags: review?(wtc)
(Assignee)

Comment 4

14 years ago
This code appears to do exactly what it says it does.  But I have misgivings
about exposing a method that is known not to be thread safe, yet has the 
potential to be used after initialization is done.  

NSS has reader/writer locks. Would performance be degraded unacceptably to 
use them to protect the OID hash tables? 
Summary: RFE: Export the function that let's an app add OID's dynamically. → RFE: Export the function that lets an app add OIDs dynamically.

Comment 5

14 years ago
If we expose this function, it needs to be thread safe.

We should measure the performance degradation from the
use of reader/writer locks to see if it is worthwhile
to expose this function.
Priority: -- → P2
Target Milestone: 3.8 → 3.9

Updated

14 years ago
Severity: normal → enhancement
Summary: RFE: Export the function that lets an app add OIDs dynamically. → Export the function that lets an app add OIDs dynamically.
(Assignee)

Comment 6

14 years ago
The current method for encoding cert names can only encode known OIDs. 
So before we can encode a name with an OID that's not compiled into secoid.c, 
we must add the OID it to the dynamic OID table.  IOW, we must be able to 
add OIDs to the OID table on the fly, after initialization is done. 
IMO, this means the patch that doesn't make it thread safe isn't good enough.

This bug blocks 211655, which blocks 210709.
Blocks: 211655

Updated

14 years ago
Target Milestone: 3.9 → 3.10
(Assignee)

Comment 7

14 years ago
Correct the dependency.  
This bug now blocks bug 210584, which blocks bug 210709.
Blocks: 210584
No longer blocks: 211655

Comment 8

14 years ago
Comment on attachment 117087 [details] [diff] [review]
SEC_AddOidEntry should return SECOidTag, not SECStatus.

Obsoleting patch as we decided that this function should be implemented in a
thread-safe manner
Attachment #117087 - Attachment is obsolete: true
Attachment #117087 - Flags: superreview?(MisterSSL)
Attachment #117087 - Flags: review?(wchang0222)
(Assignee)

Comment 9

13 years ago
I am fixing this bug as part of my work on bug 124923
Assignee: rrelyea0264 → MisterSSL
Depends on: 124923
(Assignee)

Updated

13 years ago
No longer blocks: 210584
(Assignee)

Comment 10

13 years ago
I am making this bug be a dup of 124923 instead of merely depending on that bug.

*** This bug has been marked as a duplicate of 124923 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 124923
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.