DNS: Option to flush the dns cache on demand would be very helpful

RESOLVED DUPLICATE of bug 192798

Status

()

enhancement
RESOLVED DUPLICATE of bug 192798
16 years ago
16 years ago

People

(Reporter: schatt, Assigned: dougt)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1) Gecko/20021004
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1) Gecko/20021004

In the course of my work I usually end up needing to modify /etc/hosts to test
various servers (test, production, staging) all under the same dns name.  IT
would be phenomenally helpful if there were some method of flushing the dns
cache to force Mozilla to relookup dns names on demand, without having to exit
mozilla to do so.

Reproducible: Always

Steps to Reproduce:
1. Go to a url that points to a specific service - like mozilla's home page.
2. Modify your /etc/hosts to point to a different server, under the same dns name.
3. Go to the page again, without closing the browser - all requests go to the
(cached) ip address from the original query.

Actual Results:  
Traffic gets sent to the (wrong?) original server that resolved under the dns query.

Expected Results:  
Perhaps on a shift reload, it should flush the dns cache as well, so that it
gets the correct address?
(Reporter)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 162871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
REOPEN:
did you search before filing? searching on "DNS" and "cache" in summaries would
have included bug 192798
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
If that bug summary was too vague, please email me and I'll try to make it more
searchable.

*** This bug has been marked as a duplicate of 192798 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Summary: Option to flush the dns cache on demand would be very helpful → DNS: Option to flush the dns cache on demand would be very helpful
You need to log in before you can comment on or make changes to this bug.