Dropdown lists for filters in Search Messages/Addresses don't work

VERIFIED DUPLICATE of bug 196755

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED DUPLICATE of bug 196755
16 years ago
10 years ago

People

(Reporter: Jure Repinc (JLP), Assigned: Navin Gupta)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Reproducable: always

Steps to reproduce:
1. Open Mozilla Mail&News
2. Go to Tools > Search Messages ot Tools > Search Addresses
3. Try changing the default value of dropdown in filter (for example from
Subject to Sender)

Result:
Dropdown does not change it's value to the new selected value.

Expected:
Dropdown should change it's value to the new selection.

I see the same problem in filter options for incomming mail. I noticed the
problem in Mozilla 2003030608 and it is still here in 2003030708.

Comment 1

16 years ago
I am seeing this in 2003031008

Comment 2

16 years ago
Seeing this on Linux and Solaris too with cvs 20030311. 

This is major functionality creaked and should be P1 Priority. Reporter can
you change this to Hardware=All, OS=All 

Comment 3

16 years ago
Looks like the whole UI in mail is broken (search/message filters/addressbook)
since i logged bug 196718 yesterday which may also be related

Comment 4

16 years ago
More debugging has uncovered that this only affects the "Mordern" theme.
Switching to "Classic" them and all works fine.
(Reporter)

Comment 5

16 years ago
Changing bug properties as per comments. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 6

16 years ago
Another interesting artifact is that when the (subject) drop down list goes
away, the "more" button below it didn't get repainted (there is a white line
where the
list box border was).

I'm using the Orbit 3+1 theme w/Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.4a) Gecko/20030312

Comment 7

16 years ago
*** Bug 196535 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: regression

Comment 8

16 years ago
dup of 196755 since that bug has more information in it.

*** This bug has been marked as a duplicate of 196755 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
QA Contact: laurel → esther
Resolution: --- → DUPLICATE

Comment 9

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: esther → search
You need to log in before you can comment on or make changes to this bug.