dotted hebrew text is displayed wrong; dot chars are displayed behind normal chars instead of on

RESOLVED DUPLICATE of bug 60546

Status

()

defect
RESOLVED DUPLICATE of bug 60546
16 years ago
16 years ago

People

(Reporter: t_nord, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 obsolete attachment)

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030210

In the given example (http://www.mechon-mamre.org/i/t/t0101.htm) the dotted
hebrew text ist displayed wrong. The dot chars should appear directly on the
normal chars. So that eg. points (eg. 1 dot under the char for an i) are
displayed under the chars ('alef', 'bet', ...)
This problem appears NOT in the mozilla 1.1 in Win98. It appears also in older
mozilla, then this.

Reproducible: Didn't try

Steps to Reproduce:
1. Didn't find other page's then http://www.mechon-mamre.org/ with dotted hebrew
text. 
2. To repoduce, take any dotted hebrew html with windows-1255
3.



- I use woody3.0; x11 and icewm
- the particular chars of the windows-1255 charset are more or less right.
- maybe the dots and bars, are not exactly in the right hight to the char
(hardly to see because they are displayed next to each other and not on each other)
- because of this problem the text cannot be read - maybe it can be read with
great difficulties
- the dotted hebrew text allows you to read the content right - especially here
the bible

Comment 1

16 years ago
As I and probably most developers don't know what Hebrew is supposed to look
like, is is possible for you to take a screen capture and circle the incorrect
character(s) you describe.

However, one thing that I am pretty sure is wrong is that if I highlight text
and right-click it, the Search for "..." option displays the ... part in reverse
of how the content area is rendering it.  Example: Highlight the first two
characters (what looks like an underscore and what looks like a curved n) of
body text.  Right-click the selection.  The Web Search for entry has the
underscore-looking character underneath the curved n character.  That sounds
similar to what you described so I will confirm this.

Mozilla 2003030717 WinXP SP1
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Posted image screenshot of the problem I described (obsolete) —
Please don't confuse the bug with other issues.  Some of us actually do know
what's going on, which is basically that the font display code on Linux doesn't
support combining characters.
(For that matter, neither does the selection code.)
Reporter

Comment 5

16 years ago
I tried to send you an image in this interface to describe the problem better.
But I failed.
I think comment #3 from you David is right.
Is it possible to answer the emails I get directly, or should I try to place the
images in my the web?
Reporter

Comment 6

16 years ago
OK placed two images of the problem onto my account:
http://www.stud.uni-karlsruhe.de/~upuc/hebrew1.png
http://www.stud.uni-karlsruhe.de/~upuc/hebrew2.png

- the blue char should be displayed under the red char
- hebrew is written/read from right to left
- the blue chars are the hebrew vowels; the red chars the consonants
- the "web search for "..."" is displayed like the direct text (no new problem,
it is the same)

*** This bug has been marked as a duplicate of 60546 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.