If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[qt] XRemote is set in config but qt doesn't have it

VERIFIED FIXED

Status

Core Graveyard
Ports: Qt
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: Alexander Opitz, Assigned: Alexander Opitz)

Tracking

Other Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
Removing XRemote line should prevent trouble in navigator.js line 591
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
if I read the code right, fixing this would make bookmarks show up in navigator.
Summary: [qt] XRemote is set in config but qt haven't it → [qt] XRemote is set in config but qt doesn't have it
(Assignee)

Comment 2

15 years ago
*** Bug 194751 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

15 years ago
Created attachment 116702 [details] [diff] [review]
removes line out of configure/configure.in
Comment on attachment 116702 [details] [diff] [review]
removes line out of configure/configure.in

this works, thanks!
Attachment #116702 - Flags: review+
Checking in configure;
/cvsroot/mozilla/configure,v  <--  configure
new revision: 1.1098.8.2; previous revision: 1.1098.8.1
done
Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1161.8.2; previous revision: 1.1161.8.1
done


fixed on qt branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
Hmm, I still don't get bookmarks right. I just did a clobber build on the Qt
branch, and I see no change. This is all output I got on stdin/stderr (konsole):


###!!! ASSERTION: couldn't get thread private index:
'nsThread::kIThreadSelfIndex != 0', file
/home/robert/temp/mozilla/qt-src/mozilla/xpcom/threads/nsThread.cpp, line 376
Break: at file
/home/robert/temp/mozilla/qt-src/mozilla/xpcom/threads/nsThread.cpp, line 376
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
WARNING: Trying to set p, file
/home/robert/temp/mozilla/qt-src/mozilla/modules/libpref/src/prefapi.cpp, line 1017
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file
/home/robert/temp/mozilla/qt-src/mozilla/rdf/chrome/src/nsChromeRegistry.cpp,
line 3141
WARNING: chrome: failed to get base url for
chrome://chatzilla/skin/chatzillaOverlay.css -- using wacky default, file
/home/robert/temp/mozilla/qt-src/mozilla/rdf/chrome/src/nsChromeRegistry.cpp,
line 600
WARNING: couldn't get widget helper service, file
/home/robert/temp/mozilla/qt-src/mozilla/xpfe/components/xremote/src/XRemoteService.cpp,
line 369
JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIXRemoteService.addBrowserInstance]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: Startup :: line 591"  data: no]

WARNING: nsTimeoutImpl::Release() proceeding without context., file
/home/robert/temp/mozilla/qt-src/mozilla/dom/src/base/nsGlobalWindow.cpp, line 4903
JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIAppShellService.quit]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goQuitApplication :: line 40"  data: no]

WARNING: NS_ENSURE_TRUE(mDocument) failed, file
/home/robert/temp/mozilla/qt-src/mozilla/content/base/src/nsDocumentViewer.cpp,
line 1171
WARNING: NS_ENSURE_TRUE(presShell) failed, file
/home/robert/temp/mozilla/qt-src/mozilla/content/html/content/src/nsGenericHTMLElement.cpp,
line 2719
WARNING: requested removal of nonexistent window
, file
/home/robert/temp/mozilla/qt-src/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 937
WARNING: not writing prefs because they haven't changed, file
/home/robert/temp/mozilla/qt-src/mozilla/modules/libpref/src/nsPrefService.cpp,
line 225
WARNING: nsExceptionService ignoring thread destruction after shutdown, file
/home/robert/temp/mozilla/qt-src/mozilla/xpcom/base/nsExceptionService.cpp, line 189
WARNING: Droping timer event because thread is dead, file
/home/robert/temp/mozilla/qt-src/mozilla/xpcom/threads/nsTimerImpl.cpp, line 498

WARNING: couldn't get widget helper service, file
/home/robert/temp/mozilla/qt-src/mozilla/xpfe/components/xremote/src/XRemoteService.cpp,
line 369

that is no good...
hm, maybe that configure change wasn't enough. could you try running "autoconf"
and re-making a clobber build?

Comment 8

15 years ago
OK, it's working now.

I'll open a bug for implementing XRemote in Mozilla-Qt though (I don't think
it's a requirement for getting it back into the trunk or something, but it would
really be nice to have it...)
vrfy per comment 8 & personal experience
bug for XRemote in qt is bug 197045
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.