2 forms opened successively | mouse focus lost if javascript in second tab also calls mouse focus event into form field of second form

RESOLVED DUPLICATE of bug 196646

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 196646
16 years ago
16 years ago

People

(Reporter: manohar, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

1:) open mail.yahoo.com in one tab.
2:) type in a username
3:) open mail.yahoo.com in second tab.
by the time the second tab loads, mouse focus shifts to username field of the
second tab page, also the username you are typing will be entered in the
second-tab form-field. 
problem particularly troublesome when password being entered, is displayed in
the clear-text field of second-tab-page.

Reproducible: Always

Steps to Reproduce:
1:) open mail.yahoo.com in one tab.
2:) type in a username
3:) open mail.yahoo.com in second tab.
by the time the second tab loads, mouse focus shifts to username field of the
second tab page, also the username you are typing will be entered in the
second-tab form-field. 
problem particularly troublesome when password being entered, is displayed in
the clear-text field of second-tab-page.
Actual Results:  
by the time the second tab loads, mouse focus shifts to username field of the
second tab page, also the username you are typing will be entered in the
second-tab form-field. 
problem particularly troublesome when password being entered, is displayed in
the clear-text field of second-tab-page.

Expected Results:  
mousefocus should be retained by page being loaded first.

*** This bug has been marked as a duplicate of 196646 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.