mozilla-bin crash installing CaScadeS [@ nsInstallFile::CreateAllFolders]

VERIFIED DUPLICATE of bug 186088

Status

Core Graveyard
Installer: XPInstall Engine
--
critical
VERIFIED DUPLICATE of bug 186088
15 years ago
2 years ago

People

(Reporter: Chris Casciano, Assigned: Sean Su)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
I'm getting consistant crashers trying to install CaScadeS on a 1.3 branch build
from this weekend. Other XPIs I've seen install without incident (e.g. checky &
livehttpheaders, both from mozdev)

Note, there is another outstanding crasher with CaScadeS on OS X [Bug 174663],
but the stack there looks very different from this one.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030308

Talkback IDs:
TB192725E
TB192730E

beginning of mozilla-bin.crash.log

**********

Date/Time:  2003-03-10 10:56:06 -0500
OS Version: 10.2.4 (Build 6I32)
Host:       pnhTiObject.local.

Command:    mozilla-bin
PID:        4545

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0:
 #0   0x90073c48 in mach_msg_trap
 #1   0x90005f90 in mach_msg
 #2   0x90148b10 in __CFRunLoopRun
 #3   0x90180fe4 in CFRunLoopRunSpecific
 #4   0x969a3160 in RunCurrentEventLoopInMode
 #5   0x969a3900 in GetNextEventMatchingMask
 #6   0x969a7664 in WNEInternal
 #7   0x969ad528 in WaitNextEvent
 #8   0x01b8ad00 in nsMacMessagePump::GetEvent(EventRecord&)
 #9   0x01b8abdc in nsMacMessagePump::DoMessagePump()
 #10  0x01b7f29c in nsAppShell::Run()
 #11  0x00005350 in main1(int, char**, nsISupports*)
 #12  0x000058ac in main
 #13  0x000020d4 in _start
 #14  0x00001f54 in start

Comment 1

15 years ago
Possible dup of bug 186088? Chris, please attach the complete stack trace you
excerpted in comment 0.
(Reporter)

Comment 2

15 years ago
Created attachment 116863 [details]
full crash log

there ya go greg.. and yeah.. it looks like that may be it... so used to seeing
crashes in thread 0 that i miss read this one

Comment 3

15 years ago
Resolving dup per comment 2.

*** This bug has been marked as a duplicate of 186088 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: mozilla-bin crash installing CaScadeS [nsMacMessagePump::GetEvent(EventRecord&) ?] → mozilla-bin crash installing CaScadeS [@ nsInstallFile::CreateAllFolders]
Version: Other Branch → Trunk

Comment 4

15 years ago
verified
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsInstallFile::CreateAllFolders]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.