If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After unchecking the "open unrequest windows" option, specifically requesting windows sometimes doesn't work.

RESOLVED DUPLICATE of bug 101190

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 101190
15 years ago
13 years ago

People

(Reporter: jim gosney, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

When I uncheck the "open unrequested windows" option box to prevent "popups", I
find that sometime this feature blocks windows from opening that I specifically
request.  It is a sporadic problem.  Sometimes they open, and sometimes they
don't.  

One specific URL is on CBS's SURVIVOR 6 website at
http://www.cbs.com/primetime/survivor6/.  If you click on the "opinion poll" on
the main page, sometimes it will not open the requested window.  If I turn off
this feature, this window will always open up.

Another URL that shows the problem is at the JEOPARDY website at
http://www.jeopardy.com/mini_sites/archive_header/index.html?/.
Clicking on the blue "PLAY" button should open a window to play the game, but
again, it doesn't always work when I've got the "open unrequested windows"
unchecked.

It is my understanding that this option prevents java from opening windows I
don't manually open.  But if I click on a link to open a java-related window,
they should still open, correct?


Reproducible: Sometimes

Steps to Reproduce:
1.  Go to one of the above mentioned websites.
2.  click on any link that uses Java to open a new window.
3.  (be sure that "open unrequested windows" is unchecked in the ADVANCED |
SCRIPTS & PLUGINS menu.

Comment 1

15 years ago
Jim, do you see the same problem with a new profile as well?
(Reporter)

Comment 2

15 years ago
Oliver,  I have tried it with two separate profiles.  I have also tried it on
multiple machines.  I get the same intermittent results either method.

Comment 3

14 years ago
The popup window doesn't show "sometimes" but it doesn't show when the page is
still loading. This is Mozilla's popup detection doing it's job. Duping this bug.

*** This bug has been marked as a duplicate of 101190 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.