On startup windows complains that wrong java plugin is being used for internet explorer.

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 83376
16 years ago
15 years ago

People

(Reporter: home, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030308
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030308

Have just installed the 1.3 candidate build for win32, after uninstalling 1.2.1
and deleting the Mozilla directory (i.e. a clean install). On startup a windows
popup is shown with the message:

"Java Plugin for Netscape Navigator should not be used in Microsoft Internet
Explorer. Please use Java Plugin for Microsoft Internet Explorer instead."

This has never occurred before with previous builds (including 1.3b in the short
time I tested it before the crash bug made it unusable). I uninstalled the Java
plugin, which of course stopped the problem, and then reinstalled the latest jre
from Java - 1.4.1_02, and the problem is back.

Note that IE was not running at all during testing, and cancelling the message
allowed me to use Mozilla as usual.

Reproducible: Always

Steps to Reproduce:
1. Start mozilla.
2.
3.

Actual Results:  
Popup complains that the netscape java plugin should not be used for IE.

Expected Results:  
No popup.

Using the Modern Theme, and problem occurred before any XPI's were installed.
(Reporter)

Updated

16 years ago
Flags: blocking1.3+

Comment 1

16 years ago
not sure you can decide to put that bug blocking1.3, especially when not yet
confirmed...
(Reporter)

Comment 2

16 years ago
Just following Asa's instructions on
http://www.mozillazine.org/articles/article2959.html

Just seen that another candidate has been released - will download and test this
evening.

Comment 3

16 years ago
You should check your prefs.js and user.js to see if you have altered your
useragent setting to anything containing IE. That's what produced this message
for me in the past. Starting with a fresh profile would also fix such a problem,
I think.

Comment 4

16 years ago
A quick way to find out the current UA string is Help -> About Mozilla.

Comment 5

16 years ago
Reporter, please don't set the blocking flag directly. See the guidelines under

http://www.mozillazine.org/articles/article2779.html

for more information. Note: I can't change it.
(Reporter)

Comment 6

16 years ago
Apologies. Have reset to ?. Will look for the UA spoofing string in user.js and
prefs.js ASAP. Flag should probably be set to - by someone who has permission..
Flags: blocking1.3+ → blocking1.3?
(Assignee)

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Flags: blocking1.3?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.