"open link in new window" windows should have symmetrical history

VERIFIED DUPLICATE of bug 18808

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 18808
16 years ago
10 years ago

People

(Reporter: Daniel B., Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

When a link is opened in a new window, the new window's history shouldn't be
empty.  It should be consistent with the histories of other windows, 
specifically:  It should show the history leading up to its currently displayed 
page, just as the original window shows the history leading up to its currently 
displayed page.

Consider the asymmetry of the current behavior in this example:

You start somewhere and end up at page zero.

Page A has two links you'd like to explore, so you open:
- link 1/page 1 in a new window
- link 2/page 2 in the original window.

You pick one window (based on whichever page you want to start with), traverse a
couple of links, are done with that branch, and close the window.

You return to the remaining window.  At some point (whether immediately or after
some traversal), you realize you want to go back to one of the pages (page zero 
or earlier) that led to the current page.

If you happened to pick link 1/page 1 to explore first (in the newer window), 
then you're now using the original window and can go back in the history.

However, if you happened to explore link 2/page2 first (in the original window),
then you're out of luck, since the newer window doesn't have history from
before page 1.

Note the assymmetry in the behavior:  At page 0, you branched to viewing both
page 1 and page 2, and can explore them in either other (which it symmetrical).
However, if you close one window and try to go back in the other window's
history, what you can do depends on which window was first--that's not 
symmetrical.

(Of course, opening two new windows and closing the original is symmetrical,
so obviously the term "symmetry" doesn't quite capture all of what is wanted.)

By the way, I realize this isn't how Netscape has worked recently, but it did
work like this (in 3.x? 2?) until it was broke^H^H^H^H^Hchanged.  

If it was changed because having a new window with a non-empty history confused
less-advanced users, then make it a configuration item.


Reproducible: Always

Steps to Reproduce:
1.  See example in Details text; "run" both case (close original window first,
    close new window first).

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: kasumi → docshell
You need to log in before you can comment on or make changes to this bug.