regress: colgroup / col has no support at all

RESOLVED DUPLICATE of bug 4510

Status

()

defect
RESOLVED DUPLICATE of bug 4510
17 years ago
17 years ago

People

(Reporter: ramses0, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461; EDS)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030311

Mozilla is out of compliance with HTML4.01 <COLGROUP> / <COL> examples given in 
w3.org spec.  I've done research on previous bugs which have claimed to close 
this (#4510, #68998, #91034 ?), but in today's (March 11, 2003) nightly binary, 
there is absolutely no way to tell (visually) that COLGROUP / COL is even being 
supported.

Reproducible: Always

Steps to Reproduce:
1. No support for <COLGROUP ALIGN="center">
2. No support for <COL STYLE="font-face: sans-serif">
3. No support for <COLGROUP STYLE="background: pink"> (I'm not really expecting 
this one, but it remains an issue).

Actual Results:  
Running against the W3C example table at then end of the HTML4.01 table spec 
indicates that mozilla's latest nightly is totally out of compliance with 
expected behaviour.

Expected Results:  
Render it correctly?  ;^)

See also: http://www.mozilla.org/newlayout/testcases/css/columnstyle.html for a 
mozilla testcase showing this breakage.

Fix this, please!  It's embarrasing that it doesn't work.  Not quite Sev: Major 
because I'm guessing that COLGROUP is not a widely used attribute, but I want 
to use it for Neat Dynamic Table / JS effects, and it would really irritate me 
if it didn't work in Mozilla.

See also: http://www.mozilla.org/newlayout/testcases/css/columnstyle.html for a 
mozilla testcase showing this breakage.
1) is bug 915
2) there is no column style inheritance in CSS2 
3) bug 4510
to verify that cols and colgroup work use width for cols 

<col width="1*">
<col width="2*">
<col width="3*">

should work

 
Marking duplicate of one of the two bugs this duplicates (picked one randomly).

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.