Crash when nglayout.debug.disable_xul_cache=false

RESOLVED DUPLICATE of bug 196337

Status

--
critical
RESOLVED DUPLICATE of bug 196337
16 years ago
14 years ago

People

(Reporter: relf, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Today's OS/2 build doesn't start. After choose profile dialog it crashes

------------------------------------------------------------

03-11-2003  20:59:49  SYS3175  PID 0057  TID 0001  Slot 006b
O:\INTERNET\M\MOZILLA\MOZILLA.EXE
c0000005
1e4a7da7
P1=00000001  P2=6e696b8f  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=6e696b73  EBX=009ad6b0  ECX=009c4430  EDX=009c4430
ESI=00327128  EDI=006f07c0  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1e4a7da7  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0013f96c  SSACC=f0f3  SSLIM=ffffffff
EBP=0013f9e0  FLG=00012202

GKLAYOUT.DLL 0001:002b7da7
(Reporter)

Comment 1

16 years ago
Created attachment 116935 [details]
nspr log

Hopefully, it's useful.

Comment 2

16 years ago
I'm not seeing this with the 8AM or 12AM build.

Did you try creating a new profile?

Do you have a special home page set?
(Reporter)

Comment 3

16 years ago
I've found a reason. The crash happens when pref.js contains line

user_pref("nglayout.debug.disable_xul_cache", false);

Removing that line resolves the problem.
Newly created profile also works fine.
Summary: Crash in GKLAYOUT.DLL → Crash when nglayout.debug.disable_xul_cache=false

Comment 4

16 years ago
Are you sure? false is the default.
(Reporter)

Comment 5

16 years ago
I'm sure. 
The following sequence reproduces the crash:
1. Run Mozilla
2. Create a new profile and choose it
3. Ensure that Mozilla starts fine
4. Exit Mozilla
5. Add the line
user_pref("nglayout.debug.disable_xul_cache", false);
to prefs.js of just created profile
6. Run Mozilla and choose that profile again
7. Mozilla crashes

Comment 6

16 years ago
I didn't even come this far. For me this build crashed even before the splash
screen was visible. I simply called mozilla.exe from within my installation
directory and that's what I found in PopUpLog.os2:

------------------------------------------------------------
03-12-2003  02:38:32  SYS3175  PID 009f  TID 0001  Slot 009a
F:\NETSCAPE\WARPZILLA\MOZILLA.EXE
c0000005
1d54135a
P1=00000001  P2=00000000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=003142d8  ECX=003142e8  EDX=003142e8
ESI=1d4b0940  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d54135a  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:001413b4  SSACC=f0f3  SSLIM=ffffffff
EBP=001413dc  FLG=00012246

XPCOM.DLL 0001:0005135a

Comment 7

16 years ago
Do builds of the 12th have this same problem?

Comment 8

16 years ago
For me this problem with the 11th build is gone with
mozilla-i386-pc-os2-vacpp_0312-12.zip, which started up flawlessly again.
(Reporter)

Comment 9

16 years ago
Later builds work fine.
Marking as WFM

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
reopening for dupe
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 11

16 years ago
you are vinicated. XP bug.

*** This bug has been marked as a duplicate of 196337 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.