will not launch an application to view a file

RESOLVED DUPLICATE of bug 84128

Status

Core Graveyard
File Handling
--
major
RESOLVED DUPLICATE of bug 84128
14 years ago
11 months ago

People

(Reporter: g.t. durr, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

I have observed two symptoms which I believe are related.  

#1 Upon downloading a Real Player file, Real Player 8 or RealOne launches but
hangs (have to ctrl alt del & end task).  Installing RP as a helper application
does not solve problem.  Works fine with MS Media Player & .mpg files (launches
& plays).  This works with Netscape 4.7x & Explorer 5.5 SP2

#2 Will not launch an Excel spreadsheet from a (full path) link on an internal
web page.  Spread sheet resides on an internal server & launches fine using
Netscape 4.7x & Explorer 5.5 SP2.  Again, installing Excel as a helper
application does not solve problem.

Reproducible: Always

Steps to Reproduce:
1.click on link
2.
3.

Actual Results:  
#1 Real Player launches & hangs

#2 progress bar fills in & nothing...  (does not launch Excel)

Expected Results:  
Launch appropriate software & open file.
All the code involved got heavily modified in the 1.3 cycle.  Please test a 1.3
release candidate; testing this code with 1.2.1 is pointless at this point.
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: asa → petersen
(Reporter)

Comment 2

14 years ago
per Mr. Zbarsky's suggestion, I DL'd & installed the 1.3 ver. (see below).  It
still does not launch MS Excel to open a spreadsheet.  (by g.t. durr)  

Mozilla 1.3
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
OK.  Could you please list, in detail, what dialogs you see when you click on
the excel link, what they say, and what you do?
(Reporter)

Comment 4

14 years ago
Moving the cursor over the link shows the link's path at the bottom of the
window (in this case:  file://fileservername/foldername/spreadsheetname.xls) 
Clicking on the link does exactly nothing !  It does turn color to indicate
selection briefly but goes back immediately to its original color.  Right
clicking & selecting 'open link in new window' does nothing either but it does
change the link's color.  All other links on the page work fine [as does this
one with NS 4.7X & IE 5.5].

An additional note:  another link on the page to an .xls does work but that one
is on the web server (e.g. http://webservername/.../spreadsheetname.xls)  
Ah.  HTTP content is not allowed to link to file:// content in Mozilla for
security reasons.... there is ongoing work to loosen this restriction.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.