[META] Convert <window class="dialog"> to <dialog>; or use Prompt Service

NEW
Unassigned

Status

()

Toolkit
XUL Widgets
--
trivial
16 years ago
5 years ago

People

(Reporter: Sebastian Späth, Unassigned)

Tracking

(Depends on: 2 bugs, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
Most of <window class="dialog"> should be converted to <dialog> (most occurences
are in mailnews, hence filing this here)

Reminder to myself: If all are converted, mailnews/..../dialogs.css should be
able to be removed
(Reporter)

Updated

16 years ago
Depends on: 197666
(Reporter)

Updated

16 years ago
Depends on: 197209
(Reporter)

Updated

16 years ago
Depends on: 197781
Summary: Convert <window class="dialog"> to <dialog> → [meta] Convert <window class="dialog"> to <dialog>
Copied from bug 197781 comment 0:
{
Converting [<window class="dialog"...] offers following advantages:
- there is <dialog> which is thought for dialogs (and still looks the same)
- It saves the inclusion of dialogOverlay.xul
- It saves the inclusion of the dialog <keyset> as it happens automatically
- Buttons will automatically be displayed according to chrome/OS preferences
- <OK><Cancel> buttons will not be reversed when using the "sidebar on the right
side customization" (http://mozilla.org/unix/customizing.html) as they are now
}
Depends on: 225819
Created attachment 135603 [details]
ToDoFileList as of 2003-11-15

This is the sorted result of the LXR search on [class="dialog"] done on
2003-11-15;
it includes both MailNews and the other components !

Neil:
Could you check what is actually needed for each file:
*"front-end" XUL conversion from Window to Dialog ?
*"back-end" CPP conversion to use Prompt Service ?
*... ?

Comment 3

15 years ago
Comment on attachment 135603 [details]
ToDoFileList as of 2003-11-15

>/extensions/inspector/resources/content/viewers/jsObject/evalExprDialog.xul, line 11 -- <window id="winEvalExpr" class="dialog"
Probably could be converted to use prompt service

>/profile/resources/content/confirmMigration.xul, line 19 -- class="dialog">
Should be converted to use prompt service

The others should probably just be converted to <dialog>.
Summary: [meta] Convert <window class="dialog"> to <dialog> → [META] Convert <window class="dialog"> to <dialog>
Summary: [META] Convert <window class="dialog"> to <dialog> → [META] Convert <window class="dialog"> to <dialog>; or use Prompt Service
Created attachment 135614 [details]
ToDoFileList as of 2003-11-16

Comment 2 list updated with comment 3 answer.
Attachment #135603 - Attachment is obsolete: true
Depends on: 225840
Addition to comment 1:

It also allows:
{
-<?xml-stylesheet href="chrome://communicator/skin/dialogs.css" type="text/css"?>
-<?xml-stylesheet href="chrome://messenger/skin/dialogs.css" type="text/css"?>

+<?xml-stylesheet href="chrome://global/skin/global.css" type="text/css"?>
}

Comment 6

15 years ago
Actually comment 5 may not be true for all dialogs; for instance they may have
special icons, turboDialog.xul is one example.
Depends on: 226955
Depends on: 226956
Depends on: 226958
Depends on: 226959
Depends on: 228102
Depends on: 228106
Created attachment 137218 [details]
ToDoFileList as of 2003-12-11 (v1.6b)
Attachment #135614 - Attachment is obsolete: true

Updated

14 years ago
Depends on: 249820

Comment 8

14 years ago
See also bug 78274 which contains code that will make transitioning easier for
dialogs other than the profile manager too.

Comment 9

14 years ago
*** Bug 102637 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 250609

Updated

14 years ago
Depends on: 251991
Product: Browser → Seamonkey
Assignee: Sebastian → mail
QA Contact: esther → search
No longer depends on: 228102

Comment 10

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Assignee: mail → nobody
QA Contact: search → message-display

Comment 11

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Updated

7 years ago
Depends on: 175792

Comment 12

7 years ago
Re-open meta bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: meta
Resolution: EXPIRED → ---

Updated

7 years ago
Status: REOPENED → NEW
Component: MailNews: Message Display → XUL Widgets
Product: SeaMonkey → Toolkit
QA Contact: message-display → xul.widgets
Depends on: 917563
You need to log in before you can comment on or make changes to this bug.