Should supply a default junk-mail classification weighting with Mozilla

RESOLVED DUPLICATE of bug 232019

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 232019
15 years ago
10 years ago

People

(Reporter: Adam D. Moss, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
This one is a bit tricky.

I've been using Mozilla mailnews' junkmail-filtering for a few weeks now. 
Overall I'm rather pleased with it.  BUT, its quality of classification is
rather nasty for a few days (n.b. I get about 250 emails/day), and even now
after a few weeks of training some spams still get through plus just today I got
a dreaded Falsely Considered Spam occurance.

What I'm asking for in this bug is that a basic set of weights come with Mozilla
'out of the box' so that the classification is at least moderately (hopefully
better-than-moderately) effective from the start, then training occurs from that
point onwards.

The problem with this could be the usual arguments against fixed weighting --
that spammers could learn to adapt, and that one user's weights (particularly on
the 'not spam' side) could be only a loose fit to another's needs.

I don't think that this problem is really a worry.  We wouldn't be supplying
/fixed/ weights, merely default weights -- they can be retrained away, indeed
they /will/ be retrained away, if the user has any inclination to correct
misclassification, which is the point of Mozilla's classification technique.

The benefits of supplying default weights would be:
1) Junk classification roughly works 'out of the box', training by the
user offering ongoing fine-tuning, greatly reducing the training time
needed to get near-perfect results.
2) Less chance of the (typical) non-RTFM'ing user being baffled by
the junk-filtering's not doing anything at the moment it's first
enabled and hence simply giving up on it as a 'broken' feature.

How to derive the default weights?  Probably accept weight-file
donations from the community and skim off the common heavy
weightings.  This default weighting file could be regenerated for
every milestone to keep in step with spam trends (and somewhat
destroy the miniscule chances of spams being tailored to pass
through the filters of any given release where a user
never manually corrects classification for some reason).
mass re-assign.
Assignee: naving → sspitzer

Updated

15 years ago
Severity: minor → enhancement
(Reporter)

Comment 2

15 years ago
mscott seems interested in championing this, considering the bug he filed
against himself for the same thing. :)  Reassigning!
Assignee: sspitzer → mscott
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 232019 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.