nytimes crashes (in plug-in code?) while loading [@ GetQDGlobalsBlack]

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: sonya, Assigned: peterlubczynski-bugs)

Tracking

({crash, qawanted, regression})

Trunk
PowerPC
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030314
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030314

Loading the New York Times website now crashes Mozilla reliably in the 1.4 trunk
build from 3/14, including with a new/clean profile.  I've submitted the same
crash in talkback incidents TB202158H, TB202548M, and TB202551Y.  The stack
trace seems to indicate a problem in ns4xPluginStreamListener::OnDataAvailable 
(specifically GetQDGlobalsBlack).

I believe there might be something new on the New York Times web site that
provokes some latent bug, as Camino 0.7.0 (release) also now crashes for me when
loading the site, with the same stack trace.

Reproducible: Always

Steps to Reproduce:
1. load http://www.nytimes.com
Actual Results:  
Mozilla crashes

Expected Results:  
loaded the page successfully
(Reporter)

Comment 1

16 years ago
Posted file nytimes crashlog
I see this as well (TB203696E).  It appears to be a regression, as a 1.3
candidate build renders the page without crashing.
(Reporter)

Updated

16 years ago
Keywords: crash, regression

Comment 3

16 years ago
What Flash version do you have installed?
Summary: nytimes crashes (in plugin code?) while loading → nytimes crashes (in plug-in code?) while loading [@ GetQDGlobalsBlack]
(Reporter)

Comment 4

16 years ago
Shockwave Flash 6.0 r29

Comment 5

16 years ago
sonya@cs.stanford.edu, please retest using the current Flash plug-in.
Keywords: qawanted
Whiteboard: DUPEME
(Reporter)

Comment 6

16 years ago
I can't even reproduce this now on the New York Times page with the same version
of the plugin.  Due to the reliability with which I was able to crash my build
for those two days or so, I think it is likely to have been some particular bit
of code that was in use on the page that day.  This may also, of course, be
addressed by the updated plugin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ GetQDGlobalsBlack]

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.