Scrolling/(re)drawing slow with large resized images

RESOLVED DUPLICATE of bug 163975

Status

RESOLVED DUPLICATE of bug 163975
16 years ago
10 years ago

People

(Reporter: sgrossklass, Assigned: kmcclusk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.3) Gecko/20030312

Scroll nearly to the bottom of the mentioned page.

Other URL (from bug #173453) which shows the problem:
http://java.sun.com/j2ee/tutorial/1_3-fcs/doc/Ebank.html

When web pages contain rather large images that are being displayed smaller than
they actually are, vertical scrolling (particularly via the keyboard) gets very
slow/jumpy. This also affects standalone images displayed to fit the browser
window size - when you have other windows over the respective Mozilla window and
switch back to Mozilla, it takes a while until the image gets redrawn, with
Mozilla putting the CPU under full load in the meantime. It doesn't seem to
matter what format the image is, at least it can be reproduced with both 1-bit
and 8-bit GIFs. The scrolling issues have been observed in the following builds:
1.3 final: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.3) Gecko/20030312
1.2.1 final, NT 4.0
1.3 final: Mozilla/5.0 (Windows; U; WinNT5.0; de-AT; rv:1.3) Gecko/20030312
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030315
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4a) Gecko/2003031522-sea

Reproducible: Always

Steps to Reproduce:
Look at one of the webpages and scroll until one of the affected images appears.
Actual Results:  
Slow, jumpy scrolling.

Expected Results:  
Fast and smooth scrolling.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 163975 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.