Print Preview crashes when forms are longer than a page

RESOLVED DUPLICATE of bug 193686

Status

()

Core
Print Preview
--
critical
RESOLVED DUPLICATE of bug 193686
15 years ago
15 years ago

People

(Reporter: Chris Hester, Unassigned)

Tracking

({crash})

Other Branch
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB18160126G, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

If I make a form that fits one page, Mozilla works fine, but as soon as the form
is too long for one page, Print Preview crashes it instantly.

The supplied URL shows this to happen. Remove some of the lines and it will be okay.

I have also noticed some pages appear in Print Preview with the text over the
bottom edge of the page! I think that happens with divs but can also affect forms.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
1. go to test URL provided
2. choose Print Preview from the menu
3. watch as Mozilla crashes

Expected Results:  
The page should have been rendered on screen, ready to print.

I get a Windows exception box then the Talkback screen. Sadly that didn't give
any information to pass on.
(Reporter)

Comment 1

15 years ago
Created attachment 117464 [details]
Windows stack dump

This is a copy of the Windows stack dump given after Mozilla crashes.

Comment 2

15 years ago
Confirming (1.3, win95), Talkback TB18160126G
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
OS: Windows 98 → Windows 95
Whiteboard: TB18160126G
Version: Trunk → Other Branch
nsGfxScrollFrameInner::GetScrollableView(nsIPresContext * 0x03c06158) line 1025
+ 19 bytes
nsGfxScrollFrame::Destroy(nsGfxScrollFrame * const 0x03c9f61c, nsIPresContext *
0x03c06158) line 462 + 18 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03c06158) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c9f390, nsIPresContext *
0x03c06158) line 144
nsBoxFrame::Destroy(nsBoxFrame * const 0x03c9f390, nsIPresContext * 0x03c06158)
line 1106
nsTextControlFrame::Destroy(nsTextControlFrame * const 0x03c9f390,
nsIPresContext * 0x03c06158) line 1292
nsFrameList::DestroyFrames(nsIPresContext * 0x03c06158) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x03c22890, nsIPresContext *
0x03c06158) line 144
nsLineBox::DeleteLineList(nsIPresContext * 0x03c06158, nsLineList & {...}) line 307
DestroyOverflowLines(nsIPresContext * 0x03c06158, nsIFrame * 0x03c41424, nsIAtom
* 0x00e64c38, void * 0x03c55ad8) line 4660 + 13 bytes
DestroyPropertyEnumerator(PLDHashTable * 0x03c55ee4, PLDHashEntryHdr *
0x03c55f5c, unsigned int 0, void * 0x03c06158) line 2724 + 33 bytes
PL_DHashTableEnumerate(PLDHashTable * 0x03c55ee4, int (PLDHashTable *,
PLDHashEntryHdr *, unsigned int, void *)* 0x016e2e30
DestroyPropertyEnumerator(PLDHashTable *, PLDHashEntryHdr *, unsigned int, void
*), void * 0x03c06158) line 594 + 34 bytes
FrameManager::PropertyList::Destroy(nsIPresContext * 0x03c06158) line 2734 + 21
bytes
FrameManager::DestroyPropertyList(nsIPresContext * 0x03c06158) line 2430
FrameManager::Destroy(FrameManager * const 0x03c89b88) line 533
PresShell::Destroy(PresShell * const 0x03da3fe0) line 1834
nsPrintObject::DestroyPresentation() line 110
nsPrintEngine::SetupToPrintContent(nsIDeviceContext * 0x039067d0,
nsIDOMWindowInternal * 0x00000000) line 2427
nsPrintEngine::DocumentReadyForPrinting() line 2222 + 38 bytes
nsPrintEngine::FinishPrintPreview() line 4534 + 8 bytes
nsPrintEngine::PrintPreview(nsPrintEngine * const 0x03c07ad8, nsIPrintSettings *
0x03b97120, nsIDOMWindow * 0x00000000, nsIWebProgressListener * 0x03d01414) line
1273 + 8 bytes
DocumentViewerImpl::PrintPreview(DocumentViewerImpl * const 0x03ab2aa8,
nsIPrintSettings * 0x03b97120, nsIDOMWindow * 0x00000000, nsIWebProgressListener
* 0x03d01414) line 3111 + 30 bytes
XPTC_InvokeByIndex(nsISupports * 0x03ab2aa8, unsigned int 14, unsigned int 3,
nsXPTCVariant * 0x0012ed48) line 102
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode
CALL_METHOD) line 2023 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x00e6dcb8, JSObject * 0x02e300b0, unsigned int 3,
long * 0x03c29e98, long * 0x0012eff8) line 1292 + 14 bytes
js_Invoke(JSContext * 0x00e6dcb8, unsigned int 3, unsigned int 0) line 843 + 23
bytes
js_Interpret(JSContext * 0x00e6dcb8, long * 0x0012f98c) line 2828 + 15 bytes
js_Invoke(JSContext * 0x00e6dcb8, unsigned int 1, unsigned int 2) line 860 + 13
bytes
js_InternalInvoke(JSContext * 0x00e6dcb8, JSObject * 0x00dc3c58, long 50639600,
unsigned int 0, unsigned int 1, long * 0x03aaa628, long * 0x0012fabc) line 935 +
20 bytes
JS_CallFunctionValue(JSContext * 0x00e6dcb8, JSObject * 0x00dc3c58, long
50639600, unsigned int 1, long * 0x03aaa628, long * 0x0012fabc) line 3433 + 31 bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x0155ac18, void * 0x00dc3c58,
void * 0x0304b2f0, unsigned int 1, void * 0x03aaa628, int * 0x0012fb48, int 0)
line 1063 + 33 bytes
GlobalWindowImpl::RunTimeout(nsTimeoutImpl * 0x03aaa5b0) line 4747 + 84 bytes
GlobalWindowImpl::TimerCallback(nsITimer * 0x02e4f3e8, void * 0x03aaa5b0) line 5107
nsTimerImpl::Fire() line 382 + 17 bytes
nsTimerManager::FireNextIdleTimer(nsTimerManager * const 0x014e2228) line 616
nsAppShell::Run(nsAppShell * const 0x00e82348) line 176
nsAppShellService::Run(nsAppShellService * const 0x00ea9a90) line 480
main1(int 2, char * * 0x00263f98, nsISupports * 0x00e5e0e0) line 1269 + 32 bytes
main(int 2, char * * 0x00263f98) line 1640 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e8ca90()

*** This bug has been marked as a duplicate of 193686 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.