Mozilla fails to suppress popup if page with frames is opened in a tabbed windw

RESOLVED DUPLICATE of bug 238457

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 238457
15 years ago
9 years ago

People

(Reporter: Steffen Motzer, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

53 bytes, text/html
Details
839 bytes, text/html
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

In this testcase an onunload event of a frame calls a JavaScript function of the
 parent document that opens a popup window.

Mozilla fails to suppress this popup on closing the tab if the document is
opened in a tabbed window and there is at least an other tabbed window open in
the same windows after closing the tab.


Reproducible: Always

Steps to Reproduce:
1. Download files index.html and pop.htm
2. Open a couple of tabs in a Mozilla window 
3. Load index.html in one of the open tabs
4. Close the opened tab

Actual Results:  
Mozilla opens a popup window

Expected Results:  
Mozilla should not open a popup window
(Reporter)

Comment 1

15 years ago
Created attachment 117513 [details]
file 1
(Reporter)

Comment 2

15 years ago
Created attachment 117514 [details]
file 2

Comment 3

14 years ago
Created attachment 136563 [details]
Index.htm with url updated

This file has the correct reference to test the problem.
It seems to have a strange behaviour when testing in local, let's hope that
here it works as it's supposed to work.
Attachment #117513 - Attachment is obsolete: true

Comment 4

14 years ago
Ok, it works, but it's interesting also to test the behaviour when the
attachment 136563 [details] it's a local file.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
*** Bug 227120 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Identical to bug 238457. Closing in favor of that one somewhat arbitrarily. Both
bugs are well developed with testcases. But we don't need both, and the later
one has a little more analysis.

*** This bug has been marked as a duplicate of 238457 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.