Toolbar and menu fonts become unreadably tiny when upgrading from 1.2 to 1.3

RESOLVED DUPLICATE of bug 194500

Status

RESOLVED DUPLICATE of bug 194500
16 years ago
14 years ago

People

(Reporter: eruby, Assigned: blizzard)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

I updated to Mozilla 1.3 from Mozilla 1.2 today using the Redhat 7.X RPMs. I
installed the RPMs on a Redhat 7.3 system. I am running Mozilla under KDE.

Mozilla 1.3 is not applying the KDE font settings for toolbars and menus.
Instead, I get a teeny tiny sans serif font, maybe 6 point, for all Mozilla
toolbars and menus. On a 21" monitor this is almost unreadable.

I have tried adjusting the fonts in the KDE control panel, and although every
other program I run uses the new settings, Mozilla does not.

I am going to try doing the install from source and see what happens.

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla using the Redhat 7.X RPMs
2. Start Mozilla under KDE
3. Look at the toolbars. They have a teeny tiny font that is not the font
defined in the KDE control panel.

Actual Results:  
Mozilla does not use the fonts defined in the KDE control panel.

Expected Results:  
Use the fonts defined in the KDE control panel.

I tried re-installing the themes. It does not matter which theme I use.
-> blizzard (??)
Assignee: asa → blizzard

Comment 2

16 years ago
This isn't really valid.

Mozilla is based on the GTK toolkit and picks up on GTK themes.
KDE is based on the QT toolkit. The QT port of Mozilla barely builds.

In order to modify UI fonts on a linux installation without the proper gtk
files: See http://www.mozilla.org/unix/customizing.html

Related: bug 133043


*** This bug has been marked as a duplicate of 140751 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Let me re-state the problem then: When I upgraded from Mozilla 1.2 to Mozilla
1.3 on Redhat Linux 7.3 on the KDE desktop using the RPMs supplied by
Mozilla.org, all of the fonts used by Mozilla for menus and toolbars became
very, very tiny. When running Mozilla 1.2 the fonts were perfectly readable.
Under 1.3, they were so tiny they were unreadable.

As you suggested, I checked the chrome directory. There were no userChrome.css
or userContent.css files present, just the example files. I copied the
userChrome-example.css file over to userChrome.css, found the examples to be
irrelevant, and started from scratch using the examples from
http://www.mozilla.org/unix/customizing.html. About ten minutes later I had
working fonts.

This leaves me with the questions:

* Why did the fonts change with the upgrade from 1.2 to 1.3? Shouldn't they
remain the same? Does this point to a bug in the RPM install script?

* Creating a userChrome.css file from scratch just to get Mozilla to work seems
bizarre. I thought these files were there for people who like to tweak things,
not to get basic functionality? For a default install, I would expect Mozilla to
have readable fonts right from the get-go, the fact that I didn't makes me think
I found a bug. Is this a bug or is creating a userChrome.css file after
installation the recommended approach?

* If I create better example css files that show more options that people can
use to tweak things, how do I get them included in the distribution?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Mozilla not using KDE font settings for toolbar and menu → Toolbar and menu fonts become unreadably tiny when upgrading from 1.2 to 1.3

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 194500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.