CSS background attached images doesn't render. CID: url types doesn't work for CSS

VERIFIED DUPLICATE of bug 154836

Status

MailNews Core
MIME
VERIFIED DUPLICATE of bug 154836
15 years ago
10 years ago

People

(Reporter: João S. O. Bueno, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

In a mime message, attached images which are referenced throughout
<TAG style="backgroung-image: url("cid:attachment-id")> will not
display at all. 

Attachments referenced in the IMG tag, as their source
work normally. <img src="cid:attachment-id">

Furthermore, although the image files are attached, it is impossible for
the recipient to view or save them through mozilla's interface. The mail source
must be saved as an eml file, and the image contents manually extracted from there.


Reproducible: Always

Steps to Reproduce:
1.Compose a MIME multipart message, which uses inlined background-image CSS
references
2.Open such e-mail in Mozilla's Mail News.
3.

Actual Results:  
The message is displayed incorrectly, with the background images
missing, although their files are correctly attached. Further images
on the same message, displayed with the <img> tag appear correct

Expected Results:  
The displayed message should show up the images as the background


The URL included shows the eml file of such a message.

Possibly related to bug 126309 .

Comment 1

15 years ago
I'll add the last part of the summary to bug 154836 to make it clearer and
easier to find.

*** This bug has been marked as a duplicate of 154836 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.