Mark new items in Unsent and Drafts folders to Unread

VERIFIED FIXED in mozilla1.8alpha1

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: Scott MacGregor)

Tracking

Trunk
mozilla1.8alpha1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-aviary1.0)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Opera/6.05 (Windows 2000; U)  [en]
Build Identifier: 

It would be convenient if newly-stored Draft or Unsent messages were marked as
Unread.  This would make it easier to remember these items are present, as the
folders are not generally the folders one visits.  In particular, this would
provide feedback for unexpectedly Unsent messages (mentioned as desirable in
Bug 82998) or for inexperienced users creating Drafts (mentioned as desirable
in Bug 90953).

I find myself doing this step manually whenever I can remember to; having it
automatic would be v. useful.

Reproducible: Always

Steps to Reproduce:

Updated

15 years ago
Summary: (rfe) Mark new items in Unsent and Drafts folders to Unread → Mark new items in Unsent and Drafts folders to Unread

Comment 1

15 years ago
Agreed, I really do miss this, especially with the Unsent folder. I keep
forgetting I've put some messages in there.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 2

15 years ago
I've noticed that this duplicates the WONTFIX'd bug 67267, and encompasses bug
90953 as well.

Comment 3

15 years ago
I would also like to see this feature added, but I will add that it should be
implemented in such a way so that the messages are not marked as read when you
go back and look at them later. 

MS Outlook works this way. Any message in the Drafts folder does not get
automatically marked as read when previewed or opened for editing. The only way
to mark a draft as read is to purposefully do it yourself. (Right-click the
message in the message list and choose "Mark as Read" from the pop-up menu.)

I would like to see this kind of behavior in Moz Mail/TB.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 67267 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
reopening. this was marked a dupe of a bug that was WONTFIXED well over 3 years
ago. I would like this issue to be readdressed rather than shelved by a sly
DUP'ing. 

Many people are requesting this feature and it is common in other mail clients
such as Outlook.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

14 years ago
Also note that the other bug (Bug 67267) was about "Sent/Unsent/Drafts" - this
bug specfically addresses the Unsent/Drafts issue. 

(Seems obvious to me that we wouldn't want Sent messages marked unread, but
that's an issue for another bug)
(Assignee)

Comment 7

14 years ago
Alec, if you are ok with us just marking it as unread when we save it and not
trying to prevent it from getting marked as read when you view it later, then
this would be really cheap to do.

Probably just a couple lines of code.
Assignee: sspitzer → mscott
Status: REOPENED → NEW
Target Milestone: --- → mozilla1.8alpha

Comment 8

14 years ago
yeah, that would be ideal.. 
(Reporter)

Comment 9

14 years ago
Thanks, Alec!  When I opened this bug, I intended only that the Unsent/Drafts be 
marked Unread when first stored in the folder.  While I see the potential 
usefulness, per comment 3, of having them never be marked read (at least, by 
viewing them in the preview pane), that's something I can manage myself.
(Assignee)

Comment 10

14 years ago
Created attachment 145749 [details] [diff] [review]
possible fix

After doing this, David and I decided we really don't want this behavior on by
default and having UI for this seems like useless UI cluter.

I think the comprise might be to do this just for the Local folder unsent
message case. 

A simplified patch that does it just for local unsent coming up.
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

14 years ago
Created attachment 145751 [details] [diff] [review]
better fix

Working from a tip from David, here's a slightly better fix for the case where
the message is getting saved to an IMAP drafts folder.
Attachment #145749 - Attachment is obsolete: true
(Assignee)

Comment 12

14 years ago
Comment on attachment 145751 [details] [diff] [review]
better fix

for 1.8....
Attachment #145751 - Flags: superreview?(bienvenu)
(Reporter)

Comment 13

14 years ago
Does the different remote-folder implementation in the "better fix" mean that 
messages in Drafts folders will be 'unread' after all?-- that is, that contrary 
to comment 10 it's OK to have this requested behavior by default?

The new fix sure looks like it's handling the Drafts case.
(Assignee)

Comment 14

14 years ago
Created attachment 145758 [details] [diff] [review]
even better fix

after talking to David, this is a much simpler way to do it for the local
folder case.
Attachment #145751 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #145751 - Flags: superreview?(bienvenu)
(Assignee)

Updated

14 years ago
Attachment #145758 - Flags: superreview?(bienvenu)

Comment 15

14 years ago
Comment on attachment 145758 [details] [diff] [review]
even better fix

looks good.
Attachment #145758 - Flags: superreview?(bienvenu) → superreview+

Comment 16

14 years ago
So what about someone like me that doesn't use Local Folders?
(Assignee)

Comment 17

14 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 18

14 years ago
this is fixed/changed for both imap and local folders - if it turns out that
people don't like this new default behaviour, we might have to re-evaluate.
(Reporter)

Comment 19

14 years ago
I can verify that new messages stored to Drafts (in a POP account) or Unread are 
marked as new;
I see this in
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040413

However (I hesitate to mention...) I don't see a 1.7 approval for this patch.
Is my nightly actually a proto-1.8 trunk build?


I'm also seeing inconsistent updating of the Drafts and Unsent Folders items in 
the Folder pane.  Usually, they update right away; sometimes, I need to select 
the folder before the unread count increments (and before the folder goes bold, 
if it contained no unread items previously).  I'll open another bug for that 
after I've had a chance to play with it some more.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 20

14 years ago
I just realized this wasn't checked into the aviary 1.0 branch
Whiteboard: fixed-aviary1.0
I was talking to Seth today, and he suggested that instead of marking drafts
unread it may make more sense to just make the folder bold if it contains
drafts.  That way users are reminded of the existence of unfinished drafts
without overloading the meaning of "unread".
we should be able to have a css rule for the folder pane that says:  "if it's a
drafts folder and it has messages, make it bold (or what ever)".

we should log a spin of bug about fixing this to do it that way, and not
overload unread this way.

one problem with overloading unread is messages could get marked unread, and
then you'd have the same problem.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.