All users were logged out of Bugzilla on October 13th, 2018

mozilla-1.3 gtk2 rpms dont work with java plugin

VERIFIED DUPLICATE of bug 197360

Status

()

--
minor
VERIFIED DUPLICATE of bug 197360
16 years ago
16 years ago

People

(Reporter: jrl, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

chrome             libmai.so                     mozilla-xremote-client
components         libmozjs.so                   plugins
defaults           libmsgbaseutil.so             regchrome
icons              libnssckbi.so                 regExport
libgkgfx.so        libprldap50.so                regxpcom
libgtkembedmoz.so  libxpcom.so                   res
libgtkxtbin.so     libxpistub.so                 run-mozilla.sh
libjsj.so          mozilla-bin                   searchplugins
libldap50.so       mozilla-rebuild-databases.pl  xpicleanup
[jrl@dhcppc1 mozilla-1.3]$ ./mozilla-bin
LoadPlugin: failed to initialize shared library
/usr/java/j2sdk1.4.1_02/jre/plugin/i386/ns610/libjavaplugin_oji.so
[/usr/java/j2sdk1.4.1_02/jre/plugin/i386/ns610/libjavaplugin_oji.so: undefined
symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

Reproducible: Always

Steps to Reproduce:
1. install java sdk rpm (1.4.1-02)
2. install mozilla-1.3 gtk2 rpms
3. create necessary simlinks for java
3. load mozilla, look at plugins loaded

Actual Results:  
program runs, java plugin not available

Expected Results:  
program runs, java plugin available

specific to rpm linux build - works fine in nightly and tar ball it appears

Comment 1

16 years ago
In brief: Use the tarball if you want Java support, or install a Java with
support for Gcc 3.2. See comments in dup

*** This bug has been marked as a duplicate of 197360 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Marking Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.